ГОСТ 19. ЕДИНАЯ СИСТЕМА ПРОГРАММНОЙ ДОКУМЕНТАЦИИ

ГОСУДАРСТВЕННЫЙ СТАНДАРТ СОЮЗА ССР

Единая система программной документации

ОБЩИЕ ПОЛОЖЕНИЯ

ГОСТ 19.001-77

Настоящий стандарт устанавливает целевое назначение, область распространения, классификацию и правила обозначения стандартов, входящих в комплекс Единой системы программной документации (ЕСПД).

1. Назначение ЕСПД.

1.1. Единая система программной документации - комплекс государственных стандартов, устанавливающих взаимоувязанные правила разработки, оформление и обращения программ и программной документации.

1.2. В стандартах ЕСПД устанавливают требования, регламентирующие разработку, сопровождение, изготовление и эксплуатацию программ, что обеспечивает возможность:

унификации программных изделий для взаимного обмена программами и применение ранее разработанных программ в новых разработках;

снижение трудоёмкости и повышение эффективности разработки, сопровождения, изготовления и эксплуатации программных изделий;

автоматизации изготовления и хранения программной документации.

Сопровождение программы включает анализ функционирования, развитие и совершенствование программы, а также внесение изменений в неё с целью устранения ошибок.

2. Область распространения и состав ЕСПД.

2.1. Правила и положения, установленные в стандартах ЕСПД, распространяются на программы и программную документацию для вычислительных машин, комплексов и систем независимо от их назначения и области применения.

2.2. В состав ЕСПД входят:

основополагающие и организационно-методические стандарты;

стандарты, определяющие формы и содержание программных документов, применяемых при обработке данных;

стандарты, обеспечивающие автоматизацию разработки программных документов.

2.3. Разработка организационно-методической документации, определяющей и регламентирующей деятельность организаций по разработке, сопровождению и эксплуатации программ, должна проводится на основе стандартов ЕСПД.

3. Классификация и обозначение стандартов ЕСПД.

3.1.Стандарты ЕСПД подразделяют на группы, приведённые в таблице:

Код группы | Наименование группы
0 | Общие положения
1 | Основополагающие стандарты
2 | Правила выполнения документации разработки
3 | Правила выполнения документации изготовления
4 | Правила выполнения документации сопровождения
5 | Правила выполнения эксплуатационной документации
6 | Правила обращения программной документации
7 | Резервные группы
8
9 | Прочие стандарты

3.2. Обозначение стандарта ЕСПД строят по классификационному признаку.

Обозначение стандарта ЕСПД должно состоять из:

  • цифр 19, присвоенных классу стандартов ЕСПД;
  • одной цифры (после точки), обозначающей код классификационной группы стандартов, указанной в пункте 3.1;
  • двузначного числа (после тире), указывающего год регистрации стандарта.

Пример обозначения стандарта "Единая система программной документации. Общие положения".

ГОСТ 19.001-77
 |   |  ||  |
 |   |  ||  Год регистрации стандарта
 |   |  |Порядковый номер стандарта в группе
 |   |  Классификационная группа стандартов
 |   Класс (стандарты ЕСПД)
 Категория стандарта (государственный стандарт)


Единая система программной документации

ВИДЫ ПРОГРАММ И ПРОГРАММНЫХ ДОКУМЕНТОВ.

ГОСТ 19.101-77

Настоящий стандарт устанавливает виды программ и программных документов для вычислительных машин, комплексов и систем, независимо от их назначения и области применения.

1. Виды программ.

1.1. Программу (по ГОСТ 19781-74) допускается идентифицировать и применять самостоятельно и (или) в составе других программ.

1.2. В зависимости от назначения и способа изготовления программы подразделяют на виды, приведённые в таблице 1.

Таблица 1.

Вид программы | Определение
Программа-оригинал | Программа, предназначенная для хранения и воспроизведения с неё дубликатов.
Дубликат программы | Программа, являющаяся копией программы-оригинала и предназначенная для хранения и изготовления копий.
Копия программы | Программа, предназначенная для непосредственной эксплуатации.

1.3. При изготовлении программ допускается применение любых носителей данных.

2. Виды программных документов.

2.1. К программным документам относят документы, содержащие сведения, необходимые для разработки, изготовления, сопровождения и эксплуатации программ.

2.2. Виды программных документов и их содержание приведены в таблице 2.

Таблица 2.

Вид программного документа | Содержание программного документа
Спецификация | Состав программы и документации на неё.
Ведомость держателей подлинников. | Перечень предприятий, на которых хранят оригиналы программ и подлинники программных документов.
Текст программы | Запись программы с необходимыми комментариями.
Описание программы | Сведения о логической структуре и функционировании программы.
Порядок и методика испытаний. | Требования, подлежащие проверке при испытании программы, а также порядок и методы их контроля.
Техническое задание. | Назначение и область применения программы, технические, технико-экономические и специальные требования, предъявляемые к программе, необходимые стадии и сроки разработки, виды испытаний.
Пояснительная записка | Схема алгоритма, общее описание алгоритма и (или) функционирования программы, а также обоснование принятых технических и технико-экономических решений.
Эксплуатационные документы | Сведения для обеспечения функционирования и эксплуатации программы.

2.3. Виды эксплуатационных документов и их содержание приведены в таблице 3.

Таблица 3.

Вид эксплуатационного документа | Содержание эксплуатационного документа
Ведомость эксплуатационных документов | Перечень эксплуатационных документов на программу.
Формуляр | Основные характеристики программы, комплектность и сведения об эксплуатации программы.
Общее описание | Сведения о назначении программы, области применения, применяемых методах, классе решаемых задач, ограничениях для применения, минимальной конфигурации технических средств.
Руководство системного программиста | Сведения для проверки, обеспечения функционирования и настройки программы на условия конкретного применения.
Руководство программиста | Сведения для эксплуатации программы.
Руководство оператора | Сведения для обеспечения процедуры общения оператора с вычислительной системой в процессе выполнения программы.
Описание языка | Описание синтаксиса и семантики языка программы.
Руководство по техническому обслуживанию | Сведения для применения программы при обслуживании технических средств.

2.4. Программные документы в зависимости от способа выполнения и характера применения подразделяют на подлинник, дубликат и копию по ГОСТ 2.102-68.

2.5. Виды программных документов, разрабатываемых на разных стадиях, и их коды приведены в таблице 4.

Таблица 4.

Код вида документа | Вид документа | Стадии разработки
 |  | Техническое задание | Эскизный проект | Технический проект | Рабочий проект
– | Техническое задание | · | – | – | –
– | Спецификация | – | – | – | ·
05 | Ведомость держателей подлинников | – | – | – | 0
12 | Текст программы | – | – | – | 0
13 | Описание программы | – | – | – | 0
20 | Ведомость эксплуатационных документов | – | – | – | 0
30 | Формуляр | – | – | – | 0
31 | Общее описание | – | – | – | 0
32 | Руководство системного программиста | – | – | – | 0
33 | Руководство программиста | – | – | – | 0
34 | Руководство оператора | – | – | – | 0
35 | Описание языка | – | – | – | 0
46 | Руководство по техническому обслуживанию | – | – | – | 0
51 | Порядок и методика испытаний | – | – | – | 0
81 | Пояснительная записка | – | 0 | 0 | –
90 | Документы прочие | 0 | 0 | 0 | 0

Условные обозначения:

· | - документ обязательный
0 | - необходимость составления документа определяется на этапе разработки и утверждения технического задания
– | - документ не составляют

2.6. Допускается объединять отдельные виды эксплуатационных документов (за исключением ведомости эксплуатационных документов и формуляра). Необходимость объединения этих документов указывается в техническом задании. Объединённому документу присваивают наименование и обозначение одного из объединяемых документов.

В объединённых документах должны быть приведены сведения, которые необходимо включать в каждый объединяемый документ.

2.7. На этапе разработки и утверждения технического задания определяют необходимость составления технических условий, содержащих требования к изготовлению, контролю и приёмки программы.

Технические условия разрабатывают на стадии "Рабочий проект".


Единая система программной документации

Стадии разработки.

ГОСТ 19.102-77

1. Настоящий стандарт устанавливает стадии разработки программ и программной документации для вычислительных машин, комплексов и систем независимо от их назначения и области применения.

2. Стадии разработки, этапы и содержание работ должны соответствовать указанным в таблице.

Таблица 1.

Стадии разработки | Этапы работ | Содержание работ
1. Техническое задание | Обоснование необходимости разработки программы Научно-исследовательские работы Разработка и утверждение технического задания | Постановка задачи Сбор исходных материалов Выбор и обоснование критериев эффективности и качества разрабатываемой программы. Обоснование необходимости проведения научно-исследовательских работ. Определение структуры входных и выходных данных. Предварительный выбор методов решения задач. Обоснование целесообразности применения ранее разработанных программ. Определение требований к техническим средствам. Обоснование принципиальной возможности решения поставленной задачи Определение требований к программе. Разработка технико-экономического обоснования разработки программы. Определение стадий, этапов и сроков разработки программы и документации на неё. Выбор языков программирования. Определение необходимости проведения научно-исследовательских работ на последующих стадиях. Согласование и утверждение технического задания.
2. Эскизный проект | Разработка эскизного проекта Утверждение эскизного проекта | Предварительная разработка структуры входных и выходных данных. Уточнение методов решения задачи. Разработка общего описания алгоритма решения задачи Разработка технико-экономического обоснования. Разработка пояснительной записки. Согласование и утверждение эскизного проекта.
3. Технический проект | Разработка технического проекта Утверждение технического проекта | Уточнение структуры входных и выходных данных. Разработка алгоритма решения задачи. Определение формы представления входных и выходных данных. Определение семантики и синтаксиса языка. Разработка структуры программы. Окончательное определение конфигурации технических средств. Разработка плана мероприятий по разработке и внедрению программ. Разработка пояснительной записки. Согласование и утверждение технического проекта.
4. Рабочий проект | Разработка программы Разработка программной документации Испытания программы | Программирование и отладка программы. Изготовление программы-оригинала Разработка программных документов в соответствии с требованиями ГОСТ 19.101-77. Разработка, согласование и утверждение порядка и методики испытаний. Проведение предварительных, государственных, межгосударственных, межведомственных, приёмосдаточных и других видов испытаний. Корректировка программы и программной документации по результатам испытаний.
5. Внедрение | Подготовка и передача программы. | Подготовка и передача программы и программной документации для сопровождения и (или) изготовления. Оформление и утверждение акта о передаче программы на сопровождение и (или) изготовление. Передача программы в фонд алгоритмов и программ.

Примечания:

1. Допускается исключать вторую стадию разработки, а в технико-экономических обоснованных случаях - вторую и третью стадии. Необходимость проведения этих стадий указывается в техническом задании.

2. Допускается объединять, исключать этапы работ и (или) их содержание, а также вводить другие этапы работ по согласованию с заказчиком.


Единая система программной документации

ОСНОВНЫЕ НАДПИСИ.

ГОСТ 19.104-78

Настоящий стандарт устанавливает формы, размеры, расположение и порядок заполнения основных надписей листа утверждения и титульного листа в программных документах, предусмотренных стандартами ЕСПД, независимо от способов их выполнения.

1. Основные положения.

1.1. В состав основных надписей листа утверждения и титульного листа в программных документах входят следующие структурные данные:

  • наименование министерства (ведомства);
  • наименование документа;
  • обозначение документа;
  • сведения о носителе данных, на котором представляется подлинник;
  • общее количество листов утверждения, объём документа;
  • сведения о разработчике;
  • виза нормоконтролёра;
  • отметка об учёте и хранении;
  • сведения об изменении.

2. Основные надписи листа утверждения (ЛУ).

2.1. Лист утверждения выпускается на каждый программный документ на листах бумаги формата А4, независимо от вида документа, который может быть выполнен на любом носителе данных.

2.2. Обозначение листа утверждения состоит из обозначения документа, к которому относится лист утверждения, и через дефис – шифра ЛУ.

2.3. Лист утверждения может включать несколько листов, в этом случае каждый лист нумеруется. На первом листе указывается общее количество листов, входящих в лист утверждения

2.4. Лист утверждения вносят в спецификацию и хранят на предприятии – держателе подлинника документа.

Копии листа утверждения высылают заказчику и головному предприятию.

По особому разрешению заказчика лист утверждения может быть выслан и в другие организации.

2.5. Лист утверждения заполняют по форме, приведенной на чертеже:

поле 1 - наименование министерства или ведомства, в систему которого входит организация, разработавшая данный документ.

Выше поля 1, в правом верхнем углу, при необходимости ставится специальная отметка (гриф секретности, указание "С предприятия не выносить" и т.п.);

поле 2 - в левой части поля - должности и подписи лиц, согласовавших документ от организации заказчика, в правой части поля - должности и подписи лиц, утвердивших документ от организации разработчика.

Справа от каждой подписи проставляют инициалы и фамилию лица, подписавшего документ, а ниже подписи - дату подписания;

поле 3 - полное наименование программы или программного изделия, наименование и вид документа;

поле 4 - обозначение документа и указание вида носителя данных;

поле 5 - общее количество листов утверждения;

поле 6 - в правой части поля - должности и подписи руководителя организации, выпустившей документ, руководителя подразделения, разработавшего документ, руководителя разработки (разработчика), исполнителей разработки документа и нормоконтролёра.

Справа от каждой подписи проставляют инициалы и фамилию лица, подписавшего документ, а ниже подписи - дату подписания.

При большом количестве согласующих подписей их размещают либо в левой части поля 2, либо в левой части поля 6.

Визы других должностных лиц, если они необходимы на документе, размещают на поле для подшивки ЛУ;

поле 7 - год издания (утверждения) документа (без указания слова "год" или "г");

поле 8 - отметка об учёте и хранении по ГОСТ 19.601-78;

поле 9 - строка изменений по ГОСТ 19.604-78;

поле 10 - литера документа.

Пример заполнения ЛУ приведён в обязательном приложении 1.

3. Основные надписи титульного листа.

3.1. Титульный лист заполняют по форме и правилам, установленным для ЛУ:

поле 1 - заполняют по требованию заказчика;

поле 2 - не заполняют;

поле 3 - полное наименование программы или программного изделия, наименование и вид документа. Допускается указывать сокращённое наименование программы или программного изделия;

поле 4 - обозначение документа и указание вида носителя данных;

поле 5 - указывают объём документа;

поле 6- не заполняют (при наличии ЛУ);

поле 7 - год издания (утверждения) документа (без указания слова "год" или "г");

поле 8 - отметка об учёте и хранении по ГОСТ 19.601-78;

поле 9 - строка изменений по ГОСТ 19604-78;

поле 10 - литера документа.

3.2. При наличии ЛУ на титульном листе в левом верхнем углу должна быть надпись:

Утверждён

обозначение ЛУ

Пример заполнения титульного листа приведён в обязательном приложении 2.

4. Основные надписи в тексте документа.

4.1. Содержание и правила выполнения основных надписей в программных документах на конкретных носителях данных приведены в соответствующих государственных стандартах ЕСПД.

4.2. Содержание и правила выполнения основных надписей последующих листов программных документов, выполненных печатным способом, приведены в ГОСТ 19.106-78.

Приложение 1 (обязательное).

Пример заполнения листа утверждения

 |  | Гриф секретности
 | Организация |
СОГЛАСОВАНО ____________________ должность ________________________ подпись, инициалы и фамилия "_____"___________20____г. |  | УТВЕРЖДЕНО ___________________________ должность ___________________________ подпись, инициалы и фамилия "______"_________________20______г.
наименование программы
Руководство программиста
Лист утверждения
А.В.ХХХХХ-ХХХХХХ-Х-ЛУ
вид носителя данных
общее количество листов
 |  | СОГЛАСОВАНО _____________________________ должность __________________________________ подпись, инициалы и фамилия "______"__________________20_____г. Представители предприятия-разработчика __________________________________ должность ______________________________________ подпись, инициалы и фамилия "_____"_______________________20____г.
 | 19.. г |

Приложение 2 (обязательное)

Пример заполнения титульного листа

УТВЕРЖДЁН

__________________________

обозначение листа утверждения

______________________________________________________________

наименование программы

________________________________________________________________

наименование документа

Руководство программиста

А.В.ХХХХХ-ХХХХХХ-Х

______________________________________________________

вид носителя данных

____________________________________________________________________

объём документа

19.. г

1.В.3. . . .Иванов 26.03.00. Литера


Единая система программной документации

ОБЩИЕ ТРЕБОВАНИЯ К ПРОГРАММНЫМ ДОКУМЕНТАМ.

ГОСТ 19.105-78

Настоящий стандарт устанавливает общие требования к оформлению программных документов для вычислительных машин, комплексов и систем, независимо от их назначения и области применения и предусмотренных стандартами Единой системы программной документации (ЕСПД) для любого способа выполнения документов на различных носителях данных.

1. Общие требования.

1.1. Программный документ может быть представлен на различных типах носителей данных.

1.2. Программный документ состоит из следующих условных частей:

  • титульной;
  • информационной;
  • основной;
  • регистрации изменений.

1.3. Правила оформления документа и его частей на каждом носителе данных устанавливаются стандартами ЕСПД на правила оформления документов на соответствующих носителях данных.

2. Титульная часть.

2.1. Титульная часть состоит из листа утверждения и титульного листа. Правила оформления листа утверждения и титульного листа устанавливаются по ГОСТ 19.104-78.

3. Информационная часть.

3.1. Информационная часть должна состоять из аннотации и содержания.

3.2. Необходимость включения информационной части в различные виды программных документов установлена соответствующими стандартами ЕСПД на эти документы.

3.3. В аннотации приводят сведения о назначении документа и краткое изложение его основной части.

3.4. Содержание включает перечень записей о структурных элементах основной части документа, в каждую из которых входят;

  • обозначение структурного элемента (номер раздела, подраздела и т.д.);
  • наименование структурного элемента;
  • адрес структурного элемента на носителе данных (например: номер страницы, номер файла и т.п.).

Правила обозначения структурных элементов основной части документа и их адресации устанавливаются стандартами ЕСПД на правила оформления документов на соответствующих носителях данных.

4. Основная часть.

4.1. Состав и структура основной части программного документа устанавливаются стандартами ЕСПД на соответствующие документы.

5. Часть регистрации изменений.

5.1. О каждом изменении программного документа в этой части делается запись в соответствии с требованиями ГОСТ 19.603-78.


Единая система программной документации

ТРЕБОВАНИЯ К ПРОГРАММНЫМ ДОКУМЕНТАМ, ВЫПОЛНЕННЫМ ПЕЧАТНЫМ СПОСОБОМ.

ГОСТ 19.106-78

Настоящий стандарт устанавливает правила выполнения программных документов для вычислительных машин, комплексов и систем независимо от их назначения и области применения и предусмотренных стандартами Единой системы программной документации (ЕСПД) для печатного способа выполнения.

1. Общие требования.

1.1. Состав и структура программного документа устанавливается по ГОСТ 19.105-78.

1.2. Программный документ выполняют одним из следующих печатных способов:

  • машинописным - на одной стороне листа, через два интервала; допускается через один или полтора интервала, если обеспечивается пригодность к микрофильмированию по ГОСТ 13.102-72 (разд.1);
  • машинным - на одной стороне листа, с расстояниями между основаниями строк, обеспечивающим пригодность к микрофильмированию;
  • типографским - в соответствии с требованиями, предъявленными к изданиям, изготавливаемым типографским способом.

Примечания:

1.1. При выполнении программного документа допускается сочетание печатных способов, указанных в п. 1.2. настоящего стандарта.

1.2. Допускается выполнение документа или его части рукописным способом - на одной стороне листа черными чернилами или тушью, основным чертёжным шрифтом по ГОСТ 2.304-68 с высотой букв не менее 2,5мм.

1.3. Вписывать в программные документы, выполненные машинописным, машинным и рукописным способами, отдельные слова, формулы, условные знаки (от руки чертёжным шрифтом), буквы латинского и греческого алфавитов, а так же выполнять схемы и рисунки необходимо чёрными чернилами или тушью.

1.4. При машинописном, машинном и рукописном способах выполнения документа опечатки и графические неточности, обнаруженные в процессе выполнения допускается исправлять подчисткой некачественно выполненной части текста (чертежа) и нанесением на том же листе исправленного текста (графики) машинописью или чёрной тушью в зависимости от способа выполнения документа.

Повреждение листов документов, помарки и следы неполностью удаленного текста (графики) не допускаются.

1.5. Программные документы оформляют:

  • на листах формата А4 (ГОСТ 2.301-68) при изготовлении документа машинописным или рукописным способом (форма 1). Допускается оформление на листах формата А3 (форма 3). При машинном способе выполнения документа допускаются отклонения размеров листов, соответствующих форматам А4 и А3, определяемые возможностями применяемых технических средств;
  • на листах форматов А4 и А3, предусматриваемых выходными характеристиками устройств вывода данных, при изготовлении документа машинным способом;
  • на листах типографических форматов при изготовлении документа типографским способом.

1.6. Расположение материалов программного документа осуществляется в следующей последовательности:

  • титульная часть:
    • лист утверждения (не входит в общее количество листов документа);
    • титульный лист (первый лист документа);
    • информационная часть:
    • аннотация;
    • лист содержания;
  • основная часть:
    • текст документа (с рисунками, таблицами и т.п.)
    • перечень терминов и их определений;
    • перечень сокращений;
    • приложения;
    • предметный указатель;
    • перечень ссылочных документов;
  • часть регистрации изменений:
    • лист регистрации изменений.

Перечень терминов и их определений, перечень сокращений, приложения, предметных указатель, перечень ссылочных документов выполняются при необходимости.

2. Требования к программным документам, содержащим в основном сплошной текст.

2.1. Построение документа.

2.1.1. При необходимости допускается делить документ на части. Деление на части осуществляется на уровне не ниже раздела. Каждую часть комплектуют отдельно. Всем частям присваивают обозначение документа в соответствии с ГОСТ 19.103-77.

Оформление частей осуществляется в соответствии с требованиями настоящего стандарта, при этом в конце содержания первой части следует перечислить названия остальных частей.

Допускается включение в документ частей текста программы, оформляемых в соответствии с правилами языка, на котором написан текст программы.

Нумерацию страниц документа производят в пределах каждой части, каждую часть начинают с титульного листа. Отдельная нумерация страниц документа в пределах раздела и подраздела не допускается.

2.1.2. Информационная и основная части программного документа выполняются по форме 1 ил 2, где

поле 1 - порядковый номер страницы;
поле 2 - обозначение документа;
поле 3 - текст документа;
поле 4 - строка изменений; заполняется в
соответствии с требованиями ГОСТ 19.604 - 78.

Рамку (границы) формата страниц документа допускается не наносить.

2.1.3. Аннотацию размещают на отдельной странице (страницах), снабжают заголовком "АННОТАЦИЯ", нумеруют и включают в содержание документа.

2.1.4. Содержание документа размещают на отдельной странице (страницах), снабжают заголовком "СОДЕРЖАНИЕ" и включают в общее количество страниц документа. В содержании документа дается перечисление наименований разделов и подразделов и номеров страниц.

2.1.5. Текст каждого документа, при необходимости, разбивается на пункты, а пункты - на подпункты, независимо от того, разделён документ на части, разделы и подразделы или нет.

2.1.6. Структурными элементами текста документа являются разделы, подразделы, пункты, подпункты и перечисления.

Раздел - первая ступень деления, обозначенная номером и снабжённая заголовком.
Подраздел - часть раздела, обозначенная номером и имеющая заголовок.
Пункт - часть раздела или подраздела, обозначенная номером. Может иметь заголовок. Каждый пункт текста начинается с абзаца.
Подпункт - часть пункта, обозначенная номером, может иметь заголовок.
Перечисление - логически выделенная часть текста, не имеющая номера.

При отсутствии разделов в тексте документа его первым структурным элементом является пункт. Допускается помещать текст между заголовками раздела и подраздела, между заголовками подраздела и пункта.

2.1.7. Заголовка разделов пишут прописными буквами и размещают симметрично относительно правой и левой границ текста. Заголовки подразделов записывают с абзаца строчными буквами (кроме первой прописной). Допускается при машинном способе выполнения документа заголовки подразделов и подпунктов записывать шрифтом, имеющимся на печатающем устройстве. Переносы слов в заголовках не допускаются. Точку в конце заголовка не ставят. Каждый раздел рекомендуется начинать с нового листа.

2.1.8. Расстояние между заголовком и последующим текстом, а также между заголовками раздела и подраздела должно быть равно:

  • при выполнении документа машинописным способом - двум интервалам;
  • при выполнении рукописным способом - 10 мм;
  • при выполнении машинным способом - не менее трёх высот шрифта.

Для разделов и подразделов, текст которых записывают на одной странице с текстом предыдущего раздела, расстояние между последней строкой текста и последующим заголовком должно быть равно:

  • при выполнении документа машинописным способом - трём интервалам;
  • при выполнении рукописным способом - не менее 15 мм;
  • при выполнении машинным способом - не менее четырёх высот шрифта.

Расстояние между основаниями строк заголовка принимают такие же, как и в тексте. При типографском способе издания документов указанные расстояния оформляют по правилам для типографских изданий.

2.1.9. Разделы, подразделы, пункты и подпункты следует нумеровать арабскими цифрами с точкой. Разделы должны иметь порядковый номер (1,2 и т.д.). В пределах раздела должна быть сквозная нумерация по всем подразделам, пунктам и подпунктам, входящим в данный раздел. Нумерация подразделов включает номер раздела и порядковый номер полраздела, входящего в данный раздел, разделённые точкой (2.1; 3.1 и т.д.). При наличии разделов и подразделов к номеру полраздела после точки добавляют порядковый номер пункта и подпункта (3.1.1, 3.1.1.1 и т.д.)

Пример структуры текста программного документа и нумерации его разделов, подразделов, пунктов и подпунктов приведён в обязательном приложении.

2.1.10. Внутри подразделов, пунктов и подпунктов могут быть даны перечисления, которые рекомендуется обозначать арабскими цифрами со скобкой 1), 2) и т.д.

Допускается выделять перечисления простановкой дефиса перед текстом. Не рекомендуется делать ссылки на элементы перечисления.

2.2. Текст документа.

2.2.1. Текст документа должен быть кратким, четким, исключающим возможность неверного толкования.

Термины и определения должны быть едиными и соответствовать установленным стандартам, а при их отсутствии - общепринятым в научно-технической литературе, и приводиться в перечне терминов.

2.2.2. Допускаются сокращения слов в тексте и надписях под иллюстрациями по ГОСТ 2.316-68. Дополнительные сокращения, принятые в документе и не входящие в ГОСТ 2.316-68, следует приводить в перечне принятых сокращений.

2.2.3. Для выделения отдельных понятий допускается изменять интервалы между словами, а также печатать отдельные слова или части текста шрифтом, отличным от печати основного текста, например:

UNCATLG - указывает, что запись каталога, относящаяся к исходному набору данных, должна быть исключена.

ТО - устройство - список - указывает носители данных, на которые осуществляется …

АВС3-91 СИНТАКСИЧЕСКАЯ ОШИБКА

ПРИЧИНА. Указанный в сообщении….

ДЕЙСТВИЯ СИСТЕМЫ. Задание не выполняется….

ДЕЙСТВИЯ ПРОГРАММИСТА. Необходимо обеспечить…

2.2.4. Необходимые пояснения к тексту документа могут оформляться сносками.

Сноска обозначается цифрой со скобкой, вынесенной на уровень линии верхнего обреза шрифта.

Если сноска относится к отдельному слову, знак сноски помещается непосредственно возле этого слова, если же к предложению целом, то в конце предложения. Текст сноски располагают в конце страницы и отделяют от основного текста линией длиной 3 см, проведённой в левой части страницы.

2.3. Иллюстрации.

2.3.1. Иллюстрации могут быть расположены в тексте документа и (или) в приложениях. Иллюстрации, если их в данном документе более одной, нумеруют арабскими цифрами в пределах всего документа. В приложениях иллюстрации нумеруются в пределах каждого приложения в порядке, установленном для основного текста документа. Ссылки на иллюстрации дают по типу: "рис.12" или "(рис.12)". Иллюстрации могут иметь тематический заголовок и подрисуночный текст, поясняющий содержание иллюстрации.

2.4. Формулы.

2.4.1. Формулы в документе, если их более одной, нумеруются арабскими цифрами, номер ставят с правой стороны страницы, в скобках на уровне формулы.

В пределах всего документа или его частей, в случае деления документа на части, формулы имеют сквозную нумерацию.

Ссылки в тексте на порядковый номер формулы дают в скобках, например: "в формуле (3)". При делении документа на части номер части ставится перед порядковым номером формулы и отделяется от последней точкой, например: "в формуле (1.4)"

2.4.2. Значение символов, входящих в формулу, должны быть приведены непосредственно под формулой. Значение каждого символа печатают с новой строки в той последовательности, в какой они приведены в формуле. Первая строка расшифровки должна начинаться со слова "где", без двоеточия после него.

2.4.3. Размерность одного и того же параметра в пределах одного документа должна быть постоянной.

2.5. Ссылки.

2.5.1. В программных документах допускаются ссылки на стандарты и другие документы. Ссылаться следует на документ в целом или на его разделы (с указанием обозначения и наименования документа, номера и наименования раздела или приложения). Допускается указывать только обозначение документа и (или) разделов без указания их наименований. Ссылки на отдельные подразделы, пункты и иллюстрации другого документа не допускаются. Допускаются ссылки внутри документа на пункты, иллюстрации и отдельные подразделы.

2.6. Таблицы

2.6.1. Цифровой материал для достижения лучшей наглядности и сравнимости показателей, как правило, следует оформлять в виде таблицы.

2.6.2. Оформление таблиц должно производиться в соответствии с требованиями ГОСТ 1.5.-68, раздел 1.6.

2.6.3. Сноски к таблицам располагают непосредственно под таблицей. Например:

Наборы данных, используемые для распечатки

Назначение | Стандартное имя | Используемое устройство
Для информационной распечатки | SSSSSSS* | Печатающее устройство**
Для распечатки во время выполнения программы | РРРРРРРР | Печатающее устройство**

* Имя SSSSSSS должно быть задано при настройке операционной системы.

** Для уменьшения простоев центрального процессора из-за операций ввода-вывода может быть использована магнитная лента.

2.7. Примечания.

2.7.1. В примечаниях к тексту и таблицам указывают только справочные и пояснительные данные. Одно примечание не нумеруется. После слова "Примечание" ставят точку. Несколько примечаний следует нумеровать по порядку арабскими цифрами с точкой. После слова "Примечание" ставят двоеточие.

Например:

Примечание:___________________________________________________________________

___________________________________________________________________________________

или

Примечания:

1. ____________________________________________________________________________

___________________________________________________________________________________

2. ____________________________________________________________________________

___________________________________________________________________________________

2.7.2. Текст примечаний допускается печатать только через один интервал.

2.8. Сокращения.

2.8.1. Сокращения слов в тексте и надписях под иллюстрациями не допускаются, за исключением:

  • сокращений, установленных в ГОСТ 2.316-68, и общепринятых в русском языке;
  • сокращений, применяемых для обозначения программ, их частей и режимов работы, в языках управления заданиями, в средствах настройки программы и т.п., обозначаемых буквами латинского алфавита.

2.9. Приложения

2.9.1. Иллюстрированный материал, таблицы или текст вспомогательного характера допускается оформлять в виде приложений. Приложения оформляют как продолжение данного документа на последующих страницах или выпускают в виде отдельного документа.

2.9.2. Каждое приложение должно начинаться с новой страницы с указанием в правом верхнем углу слова "Приложение" и иметь тематический заголовок. При наличии в документе более одного приложения все приложения нумеруют арабскими цифрами (без знака №), например:

Приложение 1, Приложение 2 и т.д.

При выпуске приложения отдельным документом, на титульном листе под наименованием документа следует указывать слово "Приложение", а при наличии нескольких приложений указывают также его порядковый номер.

2.9.3. Содержание каждого приложения, при необходимости, разбивают на разделы, подразделы, пункты и подпункты, нумеруемые отдельно по каждому отдельному приложению.

2.9.4. Нумерация страниц документа и приложений, входящих в состав документа, должна быть сквозная, если приложения не выполняются отдельным документом.

2.9.5. На приложения должны быть даны ссылки в основном тексте документа. Все приложения должны быть перечислены в листе "Содержание".

3. Требования к программным документам, содержащим текст, разбитый на графы.

3.1. Программные документы, содержащие текст, разбитый на графы, при необходимости разделяют на разделы и подразделы, которые не нумеруют. Допускается линии, разграничивающие строки и графы, не наносить.

3.2. Наименования разделов и подразделов записывают в виде заголовков строчными буквами (кроме первой прописной) и подчёркивают. Расстояние между заголовком и последующим текстом, между текстом и последующим заголовком и между заголовками должны соответствовать указанным в п. 2.1.8 настоящего стандарта.

3.3. Примечания в документе оформляются в порядке, изложенном в п. 2.7 настоящего стандарта.

3.4. В таблицах и формах, имеющих строки, все записи размещают на каждой строке в один ряд. Записи не должны сливаться с линиями, разграничивающими строки и графы. Следует оставлять свободные строки между разделами и подразделами, а в документах большого объёма - также внутри разделов и подразделов.


Единая система программной документации

ТЕХНИЧЕСКОЕ ЗАДАНИЕ, ТРЕБОВАНИЯ К СОДЕРЖАНИЮ И ОФОРМЛЕНИЮ.

ГОСТ 19.201-78

Настоящий стандарт устанавливает порядок построения и оформления технического задания на разработку программы или программного изделия для вычислительных машин, комплексов и систем независимо от их назначения и области применения.

1. Общие положения.

1.1. Техническое задание оформляют в соответствии с ГОСТ 19.106-78 на листах формата А4 и А3 по ГОСТ 2.301-68, как правило, без заполнения полей листа. Номера листов (страниц) проставляют в верхней части листа над текстом.

1.2. Лист утверждения и титульный лист оформляют в соответствии с ГОСТ 19.104-78. Информационную часть (аннотацию и содержание), лист регистрации изменений допускается в документ не включать.

1.3. Для внесения изменений и дополнений в техническое задние на последующих стадиях разработки программы или программного изделия выпускают дополнение к нему. Согласование и утверждение дополнения к техническому заданию проводят в том же порядке, который установлен для технического задания

1.4. Техническое задание должно содержать следующие разделы:

  • наименование и область применения;
  • основание для разработки;
  • назначение разработки;
  • технические требования к программе или программному изделию;
  • технико-экономические показатели;
  • стадии и этапы разработки;
  • порядок контроля и приёмки;
  • приложения.

В зависимости от особенностей программы или программного изделия допускается уточнять содержание разделов, вводить новые разделы или объединять отдельные из них.

2. Содержание разделов.

2.1. В разделе "Наименование и область применения" указывают наименование, краткую характеристику области применения программы или программного изделия и объекта, в котором используют программу или программное изделие.

2.2. В разделе "Основание для разработки" должны быть указаны:

  • документ (документы), на основании которых ведется разработка;
  • организация, утвердившая этот документ, и дата его утверждения;
  • наименование и (или) условное обозначение темы разработки.

2.3. В разделе " Назначение разработки" должно быть указано функциональное и эксплуатационное назначение программы или программного изделия.

2.4. Раздел "Технические требования к программе или программному изделию" должен содержать следующие подразделы:

  • требования к функциональным характеристикам;
  • требования к надёжности;
  • условия эксплуатации;
  • требования к составу и параметрам технических средств;
  • требования к информационной и программной совместимости;
  • требования к маркировке и упаковке;
  • требования к транспортированию и хранению;
  • специальные требования.

2.4.1. В подразделе "Требования к функциональным характеристикам" должны быть указаны требования к составу выполняемых функций, организации входных и выходных данных, временным характеристикам и т.п.

2.4.2. В подразделе "Требования к надёжности" должны быть указаны требования к обеспечению надёжного функционирования (обеспечение устойчивого функционирования, контроль входной и выходной информации, время восстановления после отказа и т.п.)

2.4.3. В подразделе "Условия эксплуатации" должны быть указаны условия эксплуатации (температура окружающего воздуха, относительная влажность и т.п. для выбранных типов носителей данных), при которых должны обеспечиваться заданные характеристики, а также вид обслуживания, необходимое количество и квалификация персонала.

2.4.4. В подразделе " Требования к составу и параметрам технических средств" указывают необходимый состав технических средств с указанием их технических характеристик.

2.4.5. В подразделе " Требования к информационной и программной совместимости" должны быть указаны требования к информационным структурам на входе и выходе и методам решения, исходным кодам, языкам программирования. При необходимости должна обеспечиваться защита информации и программ.

2.4.6. В подразделе "Требования к маркировке и упаковке" в общем случае указывают требования к маркировке программного изделия, варианты и способы упаковки.

2.4.7. В подразделе " требования к транспортированию и хранению" должны быть указаны для программного изделия условия транспортирования, места хранения, условия хранения, условия складирования, сроки хранения в различных условиях.

2.5. В разделе "Технико-экономические показатели" должны быть указаны: ориентировочная экономическая эффективность, предполагаемая годовая потребность, экономические преимущества разработки по сравнению с лучшими отечественными и зарубежными образцами или аналогами.

2.6. В разделе "Стадии и этапы разработки" устанавливают необходимые стадии разработки, этапы и содержание работ (перечень программных документов, которые должны быть разработаны, согласованы и утверждены), а также, как правило, сроки разработки и определяют исполнителей.

2.7. В разделе "Порядок контроля и приёмки" должны быть указаны виды испытаний и общие требования к приёмке работы.

2.8. В приложениях к техническому заданию, при необходимости, приводят:

  • перечень научно-исследовательских и других работ, обосновывающих разработку;
  • схемы алгоритмов, таблицы, описания, обоснования, расчёты и другие документы, которые могут быть использованы при разработке;
  • другие источники разработки.


Единая система программной документации

СПЕЦИФИКАЦИЯ, ТРЕБОВАНИЯ К СОДЕРЖАНИЮ И ОФОРМЛЕНИЮ.

ГОСТ 19.202-78

1. Настоящий стандарт устанавливает форму и порядок составления программного документа "Спецификация", определённого ГОСТ 19.101-77.

2. Структура и оформление документа устанавливаются в соответствии с ГОСТ 19.105-78. Информационную часть (аннотацию и содержание) допускается в документ не вносить.

3. Спецификацию выпускают на каждую программу. Форма спецификации приведена в обязательном приложении.

4. Спецификация в общем случае должна содержать разделы:

  • документация;
  • входящие программы.

Наименование каждого раздела указывают в виде заголовка в графе "Наименование" .Для документов, выполненных печатным способом, заголовок подчёркивают.

5. В раздел "Документация" вносят программные документы на данную программу, кроме спецификации, в порядке возрастания кода вида документа, входящего в обозначение.

Далее записывают заимствованные программные документы. Запись их производится в порядке возрастания кодов организаций (предприятий)-разработчиков и далее в порядке возрастания кода вида документа, входящего в обозначение.

6. После каждого раздела спецификации необходимо оставлять несколько свободных строк для дополнительных записей.

7. Графы спецификаций заполняют следующим образом:

  • в графе "Обозначение" указывают:
    • в разделе "Документация" - обозначение вписываемых документов программы;
    • в разделе "Входящие программы" - обозначение спецификаций программ, входящих в данную программу;
  • в графе "Наименование" указывают:
    • в разделе "Документация" для документов на данную программу записывают только наименование и вид документа;
    • для заимствованных документов - полное наименование программы, наименование и вид документа.
  • в графе "Примечание" указывают дополнительные сведения, относящиеся к записанным в спецификации программам.


Единая система программной документации

ТЕКСТ ПРОГРАММЫ. ТРЕБОВАНИЯ К СОДЕРЖАНИЮ И ОФОРМЛЕНИЮ.

ГОСТ 19.401-78

1. Настоящий стандарт устанавливает требования к содержанию и оформлению программного документа "Текст программы", определённого ГОСТ 19.101-77.

2. Структуру и оформление документа устанавливают в соответствии с ГОСТ 19.105-78. Составление информационной части (аннотация и содержание) является обязательным.

3. Основная часть документа должна состоять из текстов одного или нескольких разделов, которым даны наименования.

Допускается вводить наименования также и для совокупности разделов.

4. Каждый из этих разделов реализуется одним из типов символической записи, например:

  • символическая запись на исходном языке;
  • символическая запись на промежуточных языках;
  • символическое представление машинных кодов и т.п.

В символическую запись разделов рекомендуется включать комментарии, которые могут отражать, например, функциональное назначение, структуру.


Единая система программной документации

ОПИСАНИЕ ПРОГРАММЫ.

ГОСТ 19.402-78.

1. Настоящий стандарт устанавливает состав и требования к содержанию программного документа "Описание программы", определённого ГОСТ 19.101-77.

2. Структуру и оформление документа устанавливают в соответствии с ГОСТ 19.105-78. Составление информационной части (аннотации и содержания) является обязательным.

3. Основная часть документа должна состоять из вводной части и следующих разделов:

  • функциональное назначение;
  • описание логики.

В зависимости от особенностей программы допускается введение дополнительных разделов.

4. В вводной части документа приводится информация общего характера о программе (полное наименование, обозначение. применение программы и т.п.).

5. В разделе "Функциональное назначение" указывают назначение программы и приводят общее описание функционирования программы и сведения об ограничениях на применение, а также указывают типы электронных вычислительных машин и устройств, которые используются при работе.

6. В разделе "Описание логики" указывают:

  • описание структуры программы и её основных частей;
  • описание функций составных частей и связей между ними;
  • сведения о языке программирования;
  • описание входных и выходных данных для каждой из составных частей;
  • описание логики составных частей (при необходимости следует составлять описание схем программ).

При описании логики программы необходима привязка к тексту программы.


Единая система программной документации

ФОРМУЛЯР. ТРЕБОВАНИЯ К СОДЕРЖАНИЮ И ОФОРМЛЕНИЮ.

ГОСТ 19.501-78

Настоящий стандарт устанавливает правила составления программного документа "Формуляр", определённого ГОСТ 19.101-77.

1. Общие положения.

1.1. Структура и оформление документа устанавливаются в соответствии с ГОСТ 19.105-78. Информационную часть (аннотацию и содержание) допускается в документ не включать.

1.2. В основную часть документа должны входить следующие разделы:

  • общие указания;
  • общие сведения;
  • основные характеристики;
  • комплектность;
  • периодический контроль основных характеристик при эксплуатации и хранении;
  • свидетельство о приёмке;
  • свидетельство об упаковке и маркировке;
  • гарантийные обязательства;
  • сведения о рекламациях;
  • сведения о хранении;
  • сведения о закреплении программного изделия при эксплуатации;
  • сведения об изменениях;
  • особые отметки;
  • приложения.

Состав и содержание разделов документа определяют в соответствии с особенностями программных изделий.

При необходимости допускается дополнять документ другими разделами или объединять отдельные разделы, а также помещать их в приложениях.

2. Содержание разделов.

2.1. В разделе "Общие указания" приводят общие указания для обслуживающего персонала по эксплуатации программного изделия, заполнению и ведению его формуляра, например:

"Перед эксплуатацией необходимо внимательно ознакомиться с соответствующими эксплуатационными документами (приводятся наименования документов).

Формуляр должен находиться в подразделении, ответственном за эксплуатацию программного изделия"

2.2. В разделе "Общие сведения" указывают наименование программного изделия, его обозначение, наименование предприятия изготовителя, номер программного изделия предприятия и другие общие сведения о программном изделии.

2.3. В разделе "Основные характеристики" приводят необходимые при эксплуатации программного изделия значения основных характеристик (например, функциональных, надёжности и др.).

2.4. В разделе "Комплектность" перечисляют все, непосредственно входящие в программное изделие, другие программные изделия и документацию в соответствии с комплектностью, указанной в технических условиях на программное изделие. При наличии ведомости эксплуатационных документов в формуляре делают на неё ссылку без перечисления эксплуатационных документов (форма 1 обязательного приложения).

2.5. В разделе " периодический контроль основных характеристик при эксплуатации и хранении" указывают наименование измерения проверяемых характеристик, требуемую периодичность контроля (форма 2 приложения).

2.6. В разделе "Свидетельство о приёмке" приводят свидетельство о приёмке программного изделия, подписанное лицами, ответственными за приёмку (форма 3 приложения).

2.7. В разделе "Свидетельство об упаковке и маркировке" помещают сведения об упаковке программного изделия, подписанные лицами, ответственными за упаковку (форма 4 приложения).

2.8.В разделе "Гарантийные обязательства" приводят гарантийные обязательства предприятия-изготовителя.

2.9. В разделе "Сведения и рекламациях" приводят краткое изложение порядка предъявления рекламации и регистрируют все предъявленные рекламации, их содержание и принятые меры (форма 5 приложения).

2.10. В разделе "Сведения о хранении" указывают сроки хранения программного изделия (форма 6 приложения).

2.11. В разделе "Сведения о закреплении программного изделия при эксплуатации" указывают фамилии и должности лиц, за которыми закрепляют программное изделие (форма 7 приложения).

2.12. В разделе "Сведения об изменениях" указывают основание для внесения изменений, содержание изменений с указанием его порядкового номера, а также должность, фамилию и подпись лица, ответственного за проведение изменения (форма 8 приложения).

2.13. В разделе "Особые пометки" оставляют несколько чистых листов для специальных отметок, которые вносят во время эксплуатации программного изделия.

2.14. В качестве приложений к формуляру могут быть справочные материалы и дополнительные документы (например, журнал учёта работы), необходимые при эксплуатации программного изделия.

Приложение (обязательное).

Формы разделов формуляра.

Форма 1.

Комплектность

Обозначение | Наименование | Количество | Порядковый учётный номер | Примечание

Форма 2

Периодический контроль основных характеристик при эксплуатации и хранении.

Проверяемая характеристика |  | Дата проведения измерения
Наименование измерения | Величина | 20__г. |  | 20__г. |  | 20__г.
 |  | Фактическая величина | Замерил (должность подпись). | Фактическая величина | Замерил (должность подпись). | Фактическая величина | Замерил (должность подпись).

Форма 3

Свидетельство о приёмке

______________________________________ _______________________________________

наименование программного изделия обозначение

Соответствует техническим условиям (стандарту)_______________________________________

номер технических условий или стандарта

и признан(о) годным(ой) для эксплуатации

Дата выпуска_______________________________

М.П. подпись лиц ответственных за приёмку.

Форма 4.

Свидетельство об упаковке.

________________ ____________________________ номер программного изделия

наименование обозначение

предприятия __________________ упакован(а) ______________________________________

наименование или код предприятия (организации)

согласно требованиям, предусмотренным инструкцией _______________________________

обозначение

Дата упаковки _______________________

Упаковку произвел ____________________ (подпись)

Изделие после упаковки принял ___________________________ (подпись)

М.П.

Примечание. Форму заполняют на предприятии, производившем упаковку.

Форма 5.

Учет предъявленных рекламаций.

Дата | Содержание рекламации | Меры, принятые по рекламации | Подпись ответственного лица

Форма 6.

Сведения о хранении.

Дата |  | Условия хранения | Должность, фамилия и подпись лица, ответственного за хранение.
установки на хранение | снятие с хранения

Форма 7.

Сведения о закреплении программного изделия при эксплуатации.

Должность ответственного лица | Фамилия ответственного лица | Номер и дата приказа |  | Подпись ответственного лица
 |  | о назначении | об освобождении

Форма 8.

Сведения об изменениях.

Основание (входящий номер сопроводительного документа и дата) | Дата проведения изменения | Содержание изменения | Порядковый номер изменения | Должность, фамилия и подпись ответственного лица за проведение изменения | Подпись лица, ответственного за эксплуатацию программного изделия


Единая система программной документации

ОБЩЕЕ ОПИСАНИЕ. ТРЕБОВАНИЯ К СОДЕРЖАНИЮ И ОФОРМЛЕНИЮ.

ГОСТ 19.502-78.

1. Настоящий стандарт устанавливает состав и требования к содержанию программного документа "Общее описание", определённого ГОСТ 19.101-77.

2. Структуру и оформление документа устанавливают в соответствии с ГОСТ 19.105-78. Составление информационной части (аннотации и содержания) является обязательным.

3. Основная часть документа должна состоять из вводной части и следующих разделов:

  • назначение;
  • условия применения;
  • состав и функции.

В зависимости от особенностей программы допускается введение дополнительных разделов.

4. В вводной части документа приводят наименование и обозначение программы, её возможные применения.

5. В разделе "Назначение" указывают назначение, возможности программы, её основные характеристики, ограничения, накладываемые на область применения программы.

6. В разделе "Условия применения" указываются условия, необходимые для выполнения программы (требования к необходимым для данной программы техническим средствам, и другим программам, общие характеристики входной и выходной информации, а также требования и условия организационного, технического и технологического характера и т.п.).

7. В разделе "Состав и функции" указывают описание состава и функции программ, применяемых методов решения задач.

8. В приложение к общему описанию могут быть включены справочные материалы (иллюстрации, таблицы, графики, примеры и т.п.)


Единая система программной документации

ОПИСАНИЕ ЯЗЫКА.

ГОСТ 19.506-79.

Требования к содержанию и оформлению.

Настоящий стандарт устанавливает требования к содержанию и оформлению программного документа по описанию языка (программирования, управления заданиями, организации вычислительного процесса и т. п.), определенного ГОСТ 19.101-77.

Стандарт полностью соответствует СТ СЭВ 2097-80.

1. Общие положения

1.1. Структура и оформление программного документа устанавливаются в соответствии с ГОСТ 19.105-78. Составление информационной части (аннотации и содержания) является обязательным.

1.2. Описание языка должно содержать следующие разделы:

  • общие сведения;
  • элементы языка.

Допускается вводить разделы:

  • способы структурирования программы;
  • средства обмена данными;
  • встроенные элементы;
  • средства отладки программы.

В зависимости от особенностей языка допускается объединять отдельные разделы
или вводить новые. (Измененная редакция, Изм. № 1).

2. Содержание разделов

2.1. В разделе "Общие сведения" должны быть указаны назначение и описание общих характеристик языка, его возможностей, основных областей применения и другие сведения.

2.2. В разделе "Элементы языка" должно быть указано описание синтаксиса и семантики базовых и составных элементов языка.

2.3. В разделе "Способы структурирования программы" должны быть указаны способы вызова процедур передачи управления и другие элементы структурирования программы.

2.4. В разделе "Средства обмена данными" должно быть приведено описание языковых средств обмена данными (например, средства ввода-вывода, внутреннего обмена данными и т. п.).

2.5. В разделе "Встроенные элементы" должны быть приведены описание встроенных
в язык элементов (например, функции, классы и т. п.) и правила их использования.

2.2-2.5. (Измененная редакция, Изм. № 1).

2.6, 2.7. (Исключены, Изм. № 1).

2.8. В разделе "Средства отладки программы" должно быть приведено описание имеющихся в языке средств отладки программ, семантики этих средств, даны рекомендации по их применению. (Измененная редакция, Изм. № 1).

2.9. При необходимости содержание разделов должно быть пояснено примерами.

2.10. В приложения к описанию языка могут быть включены дополнительные материалы (формализованные описания языковых средств, иллюстрации, таблицы, графики, формы бланков и т. п.).


ГОСТ 34.601-90

ГОСТ 34.601-90

Комплекс стандартов на автоматизированные системы

АВТОМАТИЗИРОВАННЫЕ СИСТЕМЫ. СТАДИИ СОЗДАНИЯ.

Information technology. Set of standards for automated systems. Stages of development.

Дата введения 01.01.1992 г.

Настоящий стандарт распространяется на автоматизированные системы (АС), используемые в различных видах деятельности (исследование, проектирование, управление и т.п.), включая их сочетания, создаваемые в организациях, объединениях и на предприятиях (далее - организациях).

Стандарт устанавливает стадии и этапы создания АС. В приложении 1 приведено содержание работ на каждом этапе.

1. Общие положения.

1.1. Процесс создания АС представляет собой совокупность упорядоченных во времени, взаимосвязанных, объединённых в стадии и этапы работ, выполнение которых необходимо и достаточно для создания АС, соответствующей заданным требованиям.

1.2. Стадии и этапы создания АС выделяются как части процесса создания по соображениям рационального планирования и организации работ, заканчивающихся заданным результатом.

1.3. Работы по развитию АС осуществляют по стадиям и этапам, применяемым для создания АС.

1.4. Состав и правила выполнения работ на установленных настоящим стандартом стадиях и этапах определяют в соответствующей документации организаций, участвующих в создании конкретных видов АС.

Перечень организаций, участвующих в работах по созданию АС, приведён в приложении 2.

2. Стадии и этапы создания АС.

2.1. Стадии и этапы создания АС в общем случае приведены в таблице.

Стадии | Этапы работ
1. Формирование требований к АС | 1.1. Обследование объекта и обоснование необходимости создания АС. 1.2. Формирование требований пользователя к АС. 1.3. Оформление отчёта о выполненной работе и заявки на разработку АС (тактико-технического задания)
2. Разработка концепции АС. | 2.1. Изучение объекта. 2.2. Проведение необходимых научно-исследовательских работ. 2.3. Разработка вариантов концепции АС, удовлетворяющего требованиям пользователя. 2.4. Оформление отчёта о выполненной работе.
3. Техническое задание. | 3.1. Разработка и утверждение технического задания на создание АС.
4. Эскизный проект. | 4.1. Разработка предварительных проектных решений по системе и её частям. 4.2. Разработка документации на АС и её части.
5. Технический проект. | 5.1. Разработка проектных решений по системе и её частям. 5.2. Разработка документации на АС и её части. 5.3. Разработка и оформление документации на поставку изделий для комплектования АС и (или) технических требований (технических заданий) на их разработку. 5.4. Разработка заданий на проектирование в смежных частях проекта объекта автоматизации.
6. Рабочая документация. | 6.1. Разработка рабочей документации на систему и её части. 6.2. Разработка или адаптация программ.
7. Ввод в действие. | 7.1. Подготовка объекта автоматизации к вводу АС в действие. 7.2. Подготовка персонала. 7.3. Комплектация АС поставляемыми изделиями (программными и техническими средствами, программно-техническими комплексами, информационными изделиями). 7.4. Строительно-монтажные работы. 7.5. Пусконаладочные работы. 7.6. Проведение предварительных испытаний. 7.7. Проведение опытной эксплуатации. 7.8. Проведение приёмочных испытаний.
8. Сопровождение АС | 8.1. Выполнение работ в соответствии с гарантийными обязательствами. 8.2. Послегарантийное обслуживание.

2.2. Стадии этапы, выполняемые организациями - участниками работ по созданию АС, устанавливаются в договорах и техническом задании на основе настоящего стандарта.

Допускается исключить стадию "Эскизный проект" и отдельные этапы работ на всех стадиях, объединять стадии "Технический проект" и "Рабочая документация" в одну стадию "Технорабочий проект". В зависимости от специфики создаваемых АС и условий их создания допускается выполнять отдельные этапы работ до завершения предшествующих стадий, параллельное во времени выполнение этапов работ, включение новых этапов работ

Приложение 1 (справочное)

Содержание работ.

1. На этапе 1.1. "Обследование объекта и обоснование необходимости создания в АС" общем случае проводят:

а) сбор данных об объекте автоматизации и осуществляемых видах деятельности;
б) оценку качества функционирования объекта и осуществляемых видах деятельности, выявление проблем, решение которых возможно средствами автоматизации;
в) оценку (технико-экономической, социальной и т.д.) целесообразности создания АС.

2. На этапе 1.2. "Формирование требований пользователя к АС" проводят:

а) подготовку исходных данных для формирования требований АС (характеристика объекта автоматизации, описание требований к системе, ограничения допустимых затрат на разработку, ввод в действие и эксплуатацию, эффект, ожидаемый от системы, условия создания и функционирования системы);
б) формулировку и оформление требований пользователя к АС.

3. На этапе 1.3. "Оформление отчёта о выполненной работе и заявки на разработку АС (технико-технического задания)" проводят оформление отчета о выполненных работах на данной стадии и оформление заявки на разработку АС (тактико-технического задания) или другого заменяющего её документа с аналогичным содержанием.

4. На этапах 2.1. "Изучение объекта" и 2.2. "Проведение научно-исследовательских работ" организация-разработчик проводит детальное изучение объекта автоматизации и необходимые научно-исследовательские работы (НИР), связанные с поиском путей и оценкой возможности реализации требований пользователя, оформляют и утверждают отчёты о НИР.

5. На этапе 2.3. "Разработка вариантов концепции АС и выбор варианта концепции АС, удовлетворяющего требованиям пользователя" в общем случае, проводят разработку альтернативных вариантов концепции создаваемой АС и планов их реализации; оценку необходимых ресурсов на их реализацию и обеспечение функционирования; оценку преимуществ и недостатков каждого варианта; определение порядка оценки качества и условий приёмки системы; оценку эффектов, получаемых от системы.

6. На этапе 2.4. "Оформление отчёта о выполненной работе" подготавливают и оформляют отчет, содержащий описание выполненных работ на стадии описания и обоснования предлагаемого варианта концепции системы.

7. На этапе 3.1. "Разработка и утверждение технического задания на создание АС" проводят разработку, оформление, согласование и утверждение технического задания на АС и, при необходимости, технических заданий на части АС.

8. На этапе 4.1. "Разработка предварительных проектных решений по системе и её частям" определяются: функции АС; функции подсистем, их цели и эффекты; состав комплексов задач и отдельных задач; концепция информационной базы, её укрупнённая структура; функции системы управления базой данных; состав вычислительной системы; функции и параметры основных программных средств.

9. На этапе 5.1. "Разработка проектных решений по системе и её частям" обеспечивает разработку общих решений по системе и её частям, функционально-алгоритмической структуре системы, по функциям персонала и организационной структуре, по структуре технических средств, по алгоритмам решения задач и применяемым языкам, по организации и ведению информационной базы, системе классификации и кодирования информации, по программному обеспечению.

10. На этапах 4.2. и 5.2. "Разработка документации на АС и её части" проводят разработку, оформление, согласование и утверждение документации в объёме, необходимом для описания полной совокупности принятых проектных решений и достаточном для дальнейшего выполнения работ по созданию АС. Виды документов - по ГОСТ 34.201.

11. На этапе 5.3. "Разработка и оформление документации на поставку изделий для комплектования АС и (или) технических требований (технических заданий) на их разработку" проводят: подготовку и оформление документации на поставку изделий для комплектования АС; определение технических требований и составление ТЗ на разработку изделий, не изготовляемых серийно.

12. На этапе 5.4 "Разработка заданий на проектирование в смежных частях проекта объекта автоматизации" осуществляют разработку, оформление, согласование и утверждение заданий на проектирование в смежных частях проекта объекта автоматизации для проведения строительных, электротехнических, санитарно-технических и других подготовительных работ, связанных с созданием АС.

13. На этапе 6.1 "Разработка рабочей документации на систему и её части" осуществляют разработку рабочей документации, содержащей все необходимые и достаточные сведения для обеспечения выполнения работ по вводу АС в действие и её эксплуатации, а также для поддержания уровня эксплуатационных характеристик (качества) системы в соответствии с принятыми проектными решениями, её оформление, согласование и утверждение. Виды документов по ГОСТ 34.201.

14. На этапе 6.2 "Разработка или адаптация программ" проводят разработку программ и программных средств системы, выбор, адаптацию и (или) привязку приобретаемых программных средств, разработку программной документации в соответствии с ГОСТ 19.101.

15. На этапе 7.1 "Подготовка объекта автоматизации к вводу АС в действие" проводят работы по организационной подготовке объекта автоматизации к вводу АС в действие, в том числе: реализацию проектных решений по организационной структуре АС; обеспечение подразделений объекта управления инструктивно-методическими материалами; внедрение классификаторов информации.

16. На этапе 7.2 "Подготовка персонала" проводят обучение персонала и проверку его способности обеспечить функционирование АС.

17. На этапе 7.3 "Комплектация АС поставляемыми изделиями (программными и техническими средствами, программно-техническими комплексами, информационными изделиями)" обеспечивают получение комплектующих изделий серийного и единичного производства, материалов и монтажных изделий. Проводят входной контроль их качества.

18. На этапе 7.4 "Строительно-монтажные работы" проводят: выполнение работ по строительству специализированных зданий (помещений) для размещения технических средств и персонала АС; сооружение кабельных каналов; выполнение работ по монтажу технических средств и линий связи; испытание смонтированных технических средств; сдачу технических средств для проведения пусконаладочных работ.

19. На этапе 7.5 "Пусконаладочные работы" проводят автономную наладку технических и программных средств, загрузку информации в базу данных и проверку системы её ведения; комплексную наладку всех средств системы.

20. На этапе 7.6 "Проведение предварительных испытаний" осуществляют:

а) испытания АС на работоспособность и соответствие техническому заданию в соответствии с программой и методикой предварительных испытаний;
б) устранение неисправностей и внесение изменений в документацию на АС, в том числе эксплуатационную в соответствии с протоколом испытаний;
в) оформление акта о приёмке АС в опытную эксплуатацию.

21. На этапе 7.7 "Проведение опытной эксплуатации" проводят: опытную эксплуатацию АС; анализ результатов опытной эксплуатации АС; доработку (при необходимости) программного обеспечения АС; дополнительную наладку (при необходимости) технических средств АС; оформление акта о завершении опытной эксплуатации.

22. На этапе 7.8 "Проведение приёмочных испытаний" проводят:

а) испытания на соответствие техническому заданию в соответствии с программой и методикой приёмочных испытаний;
б) анализ результатов испытания АС и устранение недостатков, выявленных при испытаниях;
в) оформление акта о приёмке АС в постоянную эксплуатацию.

23. На этапе 8.1 "Выполнение работ в соответствии с гарантийными обязательствами" осуществляются работы по устранению недостатков, выявленных при эксплуатации АС в течении установленных гарантийных сроков, внесению необходимых изменений в документацию по АС.

24. На этапе 8.2 "Послегарантийное обслуживание" осуществляют работы по:

а) анализу функционирования системы;
б) выявлению отклонений фактических эксплуатационных характеристик АС от проектных значений;
в) установлению причин этих отклонений;
г) устранению выявленных недостатков и обеспечению стабильности эксплуатационных характеристик АС;
д) внесению необходимых изменений в документацию на АС.

Приложение 2 (справочное)

Перечень организаций, участвующих в работах по созданию АС.

1. Организация-заказчик (пользователь), для которой создаются АС и которая обеспечивает финансирование, приемку работ и эксплуатацию АС, а также выполнение отдельных работ по созданию АС.

2. Организация-разработчик, которая осуществляет работы по созданию АС, представляет заказчику совокупность научно-технических услуг на разных стадиях и этапах создания, а также разрабатывает и поставляет различные программные и технические средства АС.

3. Организация-поставщик, которая изготавливает и поставляет программные и технические средства по заказу разработчика или заказчика.

4. Организация-генпроектировщик объекта автоматизации.

5. Организации-проектировщики различных частей проекта объекта автоматизации для проведения строительных, электротехнических, санитарно-технических и других подготовительных работ, связанных с созданием АС.

6. Организации строительные, монтажные, наладочные и другие.

Примечания:

а) в зависимости от условий создания АС возможны различные совмещения функций заказчика, разработчика, поставщика и других организаций, участвующих в работах по созданию АС;
б) стадии и этапы выполняемых ими работ по созданию АС определяются на основании настоящего стандарта.


ГОСТ 34.602-89

УДК 668.012.011.56:006.354 Группа П87

ГОСТ 34.602-89

ИНФОРМАЦИОННАЯ ТЕХНОЛОГИЯ

Комплекс стандартов на автоматизированные системы.

Техническое задание на создание автоматизированной системы.

Information technology. Set of standards for automated systems. Technical directions for developing of automated system

ОКСТУ 0034

Дата введения 01.01.1990.

Настоящий стандарт распространяется на автоматизированные системы (АС) для автоматизации различных видов деятельности (управление, проектирование, исследование и т. п.), включая их сочетания, и устанавливает состав, содержание, правила оформления документа “Техническое задание на создание (развитие или модернизацию) системы” (далее - ТЗ на АС).

Рекомендуемый порядок разработки, согласования и утверждения ТЗ на АС приведен в приложении 1.

1. ОБЩИЕ ПОЛОЖЕНИЯ

1.1. ТЗ на АС является основным документом, определяющим требования и порядок создания (развития или модернизации - далее создания) автоматизированной системы, в соответствии с которым проводится разработка АС и ее приемка при вводе в действие.

1.2. ТЗ на АС разрабатывают на систему в целом, предназначенную для работы самостоятельно или в составе другой системы.

Дополнительно могут быть разработаны ТЗ на части АС: на подсистемы АС, комплексы задач АС и т. п. в соответствии с требованиями настоящего стандарта; на комплектующие средства технического обеспечения и программно-технические комплексы в соответствии со стандартами ЕСКД и СРПП; на программные 1 средства в соответствии со стандартами ЕСПД; на информационные изделия в соответствии с ГОСТ 19.201 и НТД, действующей в ведомстве заказчика АС.

Примечание. В ТЗ на АСУ для группы взаимосвязанных объектов следует включать только общие для группы объектов требования. Специфические требования отдельного объекта управления следует отражать в ТЗ на АСУ этого объекта.

1.3. Требования к АС в объеме, установленном настоящим стандартом, могут быть включены в задание на проектирование вновь создаваемого объекта автоматизации. В этом случае ТЗ на АС не разрабатывают.

1.4. Включаемые в ТЗ на АС требования должны соответствовать современному уровню развития науки и техники и не уступать аналогичным требованиям, предъявляемым к лучшим современным отечественным и зарубежным аналогам. У Задаваемые в ТЗ на АС требования не должны ограничивать разработчика системы в поиске и реализации наиболее эффективных технических, технико-экономических и других решений.

1.5. ТЗ на АС разрабатывают на основании исходных данных в том числе содержащихся в итоговой документации стадии “Исследование и обоснование создания АС”, установленной ГОСТ 24.601.

1.6. В ТЗ на АС включают только те требования, которые дополняют требования к системам данного вида (АСУ, САПР, АСНИ и т. д.), содержащиеся в действующих НТД, и определяются спецификой конкретного объекта, для которого создается система.

1.7. Изменения к ТЗ на АС оформляют дополнением или подписанным заказчиком и разработчиком протоколом. Дополнение или указанный протокол являются неотъемлемой частью ТЗ на АС. На титульном листе ТЗ на АС должна быть запись “Действует с ... ”.

2. СОСТАВ И СОДЕРЖАНИЕ

2.1. ТЗ на АС содержит следующие разделы, которые могут быть разделены на подразделы:

  • общие сведения;
  • назначение и цели создания (развития) системы;
  • характеристика объектов автоматизации;
  • требования к системе;
  • состав и содержание работ по созданию системы; .
  • порядок контроля и приемки системы;
  • требования к составу и содержанию работ по подготовке объекта автоматизации к вводу системы в действие;
  • требования к документированию;
  • источники разработки.

В ТЗ на АС могут включаться приложения.

2.2. В зависимости от вида, назначения, специфических особенностей объекта автоматизации и условий (функционирования системы допускается оформлять разделы ТЗ в /тзиде приложений, вводить дополнительные, исключать или объединять подразделы ТЗ. .

В ТЗ на части системы не включают разделы, дублирующие содержание разделов ТЗ на АС в целом.

2.3. В разделе “Общие сведения” указывают:

  • полное наименование системы и ее условное обозначение;
  • шифр темы или шифр (номер) договора;
  • наименование предприятий (объединений) разработчика и заказчика (пользователя) системы и их реквизиты;
  • перечень документов, на основании которых создается система, кем и когда утверждены эти документы;
  • плановые сроки начала и окончания работы по созданию системы;
  • сведения об источниках и порядке финансирования работ;
  • порядок оформления и предъявления заказчику результатов работ по созданию системы (ее частей), по изготовлению и наладке
  • отдельных средств (технических, программных, информационных) и программно-технических (программно-методических) комплексов системы.

2.4. Раздел “Назначение и цели создания (развития) системы” состоит из подразделов:

  • назначение системы;
  • цели создания системы.

2.4.1. В подразделе “Назначение системы” указывают вид автоматизируемой деятельности (управление, проектирование и т. п.) и перечень объектов автоматизации (объектов), на которых предполагается ее использовать.

Для АСУ дополнительно указывают перечень автоматизируемых органов (пунктов) управления и управляемых объектов.

2.4.2. В подразделе “Цели создания системы” приводят наименования и требуемые значения технических, технологических, производственно-экономических или других показателей объекта автоматизации, которые должны быть достигнуты в результате создания АС, и указывают критерии оценки достижения целей создания системы.

2.5. В разделе “Характеристики объекта автоматизации” приводят:

  • краткие сведения об объекте автоматизации или ссылки на документы, содержащие такую информацию;
  • сведения об условиях эксплуатации объекта автоматизация и характеристиках окружающей среды.

Примечание: Для САПР в разделе дополнительно приводят основные параметры и характеристики объектов проектирования.

2.6. Раздел “Требования к системе” состоит из следующих подразделов:

  • требования к системе в целом;
  • требования к функциям (задачам), выполняемым системой;
  • требования к видам обеспечения.

Состав требований к системе, включаемых в данный раздел ТЗ на АС, устанавливают в зависимости от вида, назначения, специфических особенностей и условий функционирования конкретной системы. В каждом подразделе приводят ссылки на действующие НТД, определяющие требования к системам соответствующего вида.

2.6.1. В подразделе “Требования к системе в целом” указывают:

  • требования к структуре и функционированию системы;
  • требования к численности и квалификации персонала системы и режиму его работы;
  • показатели назначения;
  • требования к надежности;
  • требования безопасности;
  • требования к эргономике и технической эстетике;
  • требования к транспортабельности для подвижных АС;
  • требования к эксплуатации, техническому обслуживанию, ремонту и хранению компонентов системы;
  • требования к защите информации от несанкционированного доступа;
  • требования по сохранности информации при авариях;
  • требования к защите от влияния внешних воздействий;
  • требования к патентной чистоте;
  • требования по стандартизации и унификации;
  • дополнительные требования.

2.6.1.1. В требованиях к структуре и функционированию системы приводят:

  • перечень подсистем, их назначение и основные характеристики, требования к числу уровней иерархии и степени централизации системы;
  • требования к способам и средствам связи для информационного обмена между компонентами системы;
  • требования к характеристикам взаимосвязей создаваемой системы со смежными системами, требования к ее совместимости, в том числе указания о способах обмена информацией (автоматически, пересылкой документов, по телефону и т. п.);
  • требования к режимам функционирования системы;
  • требования по диагностированию системы;
  • перспективы развития, модернизации системы.

2.6.1.2. В требованиях к численности и квалификации персонала да АС приводят:

  • требования к численности персонала (пользователей) АС;
  • требования к квалификации персонала, порядку его подготовки я контроля знаний и навыков;
  • требуемый режим работы персонала АС.

26.1.3. В требованиях к показателям назначения АС приводят значения параметров, характеризующие степень соответствия системы ее назначению.

Для АСУ указывают:

  • степень приспособляемости системы к изменению процессов № методов управления, к отклонениям параметров объекта управления;
  • допустимые пределы модернизации и развития системы;
  • вероятностно-временные характеристики, при которых сохраняется целевое назначение системы.

2.6.1.4. В требования к надежности включают:

  • состав и количественные значения показателей надежности для системы в целом или ее подсистем;
  • перечень аварийных ситуаций, по которым должны быть регламентированы требования к надежности, и значения соответствующих показателей;
  • требования к надежности технических средств и программного обеспечения;
  • требования к методам оценки и контроля показателей надежности на разных стадиях создания системы в соответствии с действующими нормативно-техническими документами.

2.6.1.5. В требования по безопасности включают требования до обеспечению безопасности при монтаже, наладке, эксплуатации, обслуживании и ремонте технических средств системы (защита от воздействий электрического тока, электромагнитных полей, акустических шумов и т. п.), по допустимым уровням освещенности, вибрационных и шумовых нагрузок.

2.6.1.6. В требования по эргономике и технической эстетике включают показатели АС, задающие необходимое качество взаимодействия человека с машиной и комфортность условий работы персонала.

2.6.1.7. Для подвижных АС в требования к транспортабельности включают конструктивные требования, обеспечивающие транспортабельность технических средств системы, а также требования к транспортным средствам.

2.6.1.8. В требования к эксплуатации, техническому обслуживанию, ремонту и хранению включают:

  • условия и регламент (режим) эксплуатации, которые должны обеспечивать использование технических средств (ТС) системы с заданными техническими показателями, в том числе виды и периодичность обслуживания ТС системы или допустимость работы без обслуживания;
  • предварительные требования к допустимым площадям для размещения персонала и ТС системы, к параметрам сетей энергоснабжения и т. п.;
  • требования по количеству, квалификации обслуживающего персонала и режимам его работы;
  • требования к составу, размещению и условиям хранения комплекта запасных изделий и приборов;
  • требования к регламенту обслуживания.

2.6.9. В требования к защите информации от несанкционированного доступа включают требования, установленные в НТД, действующей в отрасли (ведомстве) заказчика.

2.6.1.10. В требованиях по сохранности информации приводят перечень событий: аварий, отказов технических средств (в том числе - потеря питания) и т. п., при которых должна быть обеспечена сохранность информации в системе.

2.6.1.11. В требованиях к средствам защиты от внешних воздействий приводят:

  • требования к радиоэлектронной защите средств АС;
  • требования по стойкости, устойчивости и прочности к внешним воздействиям (среде применения).

2.6.1.12. В требованиях по патентной чистоте указывают перечень стран, в отношении которых должна быть обеспечена патентная чистота системы и ее частей.

2.6.1.13. В требования к стандартизации и унификации включают: показатели, устанавливающие требуемую степень использования стандартных, унифицированных методов реализации функций (задач) системы, поставляемых программных средств, типовых математических методов и моделей, типовых проектных решений, унифицированных форм управленческих документов, установленных ГОСТ 6.10.1, общесоюзных классификаторов технико-экономической информации и классификаторов других категорий в соответствии с облас тью их применения, требования к использованию типовых- автоматизированных рабочих мест, компонентов и комплексов.

2.6.1.14. В дополнительные требования включают:

  • требования к оснащению системы устройствами для обучения персонала (тренажерами, другими устройствами аналогичного назначения) и документацией на них;
  • требования к сервисной аппаратуре, стендам для проверки элементов системы;
  • требования к системе, связанные с особыми условиями эксплуатации;
  • специальные требования по усмотрению разработчика или заказчика системы.

2.6.2. В подразделе “Требование к функциям (задачам)”, выполняемым системой, приводят:

  • по каждой подсистеме перечень функций, задач или их комплексов (в том числе обеспечивающих взаимодействие частей системы), подлежащих автоматизации;
  • при создании системы в две или более очереди - перечень функциональных подсистем, отдельных функций или задач, вводимых в действие в 1-й и последующих очередях;
  • временной регламент реализации каждой функции, задачи (или комплекса задач);
  • требования к качеству реализации каждой функции (задачи или комплекса задач), к форме представления выходной информации, характеристики необходимой точности и времени выполнения, требования одновременности выполнения группы функций, достоверности выдачи результатов;
  • перечень и критерии отказов для каждой функции, по которой задаются требования по надежности.

2.6.3. В подразделе “Требования к видам обеспечения” в зависимости от вида системы приводят требования к математическому, информационному, лингвистическому, программному, техническому, метрологическому, организационному, методическому и другие видам обеспечения системы.

2.6.3.1. Для математического обеспечения системы приводят требования к составу, области применения (ограничения) и способам, использования в системе математических методов и моделей, типовых алгоритмов и алгоритмов, подлежащих разработке.

2.6.3.2. Для информационного обеспечения: системы приводят требования:

  • к составу, структуре и способам организации данных в системе;
  • к информационному обмену между компонентами системы;
  • к информационной совместимости со смежными системами;
  • по использованию общесоюзных и зарегистрированных республиканских, отраслевых классификаторов, унифицированных документов и классификаторов, действующих на данном предприятии;
  • по применению систем управления базами данных;
  • к структуре процесса сбора, обработки, передачи данных в системе и представлению данных;
  • к защите данных от разрушений при авариях и сбоях в электропитании системы;
  • к контролю, хранению, обновлению и- восстановлению данных;
  • к процедуре придания юридической силы документам, продуцируемым техническими средствами ас (в соответствии с ГОСТ ,6.10.4).

2.6.3.3. Для лингвистического обеспечения системы приводят требования к применению в системе языков программирования высокого уровня, языков взаимодействия пользователей и 'технических средств системы, а также требования к кодированию и декодированию данных, к языкам ввода-вывода данных, языкам манипулирования данными, средствам описания предметной области (объекта автоматизации), к способам организации диалога.

2.6.3.4. Для программного обеспечения системы приводят перечень покупных программных средств, а также требования:

  • к независимости программных средств от используемых СБТ и операционной среды;
  • к качеству программных средств, а также к способам его обеспечения и контроля;
  • по необходимости согласования вновь разрабатываемых программных средств с фондом алгоритмов и программ.

2.6.3.5. Для технического обеспечения системы приводят требования:

  • к видам технических средств, в том числе к видам комплексов технических средств, программно-технических комплексов и других комплектующих изделий, допустимых к использованию в системе;
  • к функциональным, конструктивным и эксплуатационным характеристикам средств технического обеспечения системы.

2.6.3.6. В требованиях к метрологическому обеспечению приводят:

  • предварительный перечень измерительных каналов;
  • требования к точности измерений параметров и (или) к метрологическим характеристикам измерительных каналов;
  • требования к метрологической совместимости технических средств системы;
  • перечень управляющих и вычислительных каналов системы, для которых необходимо оценивать точностные характеристики;
  • требования к метрологическому обеспечению технических и программных средств, входящих в состав измерительных каналов системы, средств, встроенного контроля, метрологической пригодности измерительных каналов и средств измерений, используемых при наладке и испытаниях системы;
  • вид метрологической аттестации (государственная или ведомственная) с указанием порядка ее выполнения и организаций, проводящих аттестацию.

2.6.3.7. Для организационного обеспечения приводят требования:

  • к структуре и функциям подразделений, участвующих в функционировании системы или обеспечивающих эксплуатацию;
  • к организации функционирования системы и порядку взаимодействия персонала АС и персонала объекта автоматизации;
  • к защите от ошибочных действий персонала системы.

2.6.3.8. Для методического обеспечения САПР приводят требования к составу нормативно-технической документации системы (перечень применяемых при ее функционировании стандартов, нормативов, методик и т. п.).

2.7. Раздел “Состав и содержание работ ;по созданию (развитию) системы” должен содержать перечень стадий и этапов работ по созданию системы в соответствии с ГОСТ 24.601, сроки их выполнения, перечень организаций — исполнителей работ, ссылки на документы, подтверждающие согласие этих организаций на участие в создании системы, или запись, определяющую ответственного (заказчик или разработчик) за проведение этих работ.

В данном разделе также приводят:

  • перечень документов, по ГОСТ 34.201, предъявляемых по окончании соответствующих стадий и этапов работ;
  • вид и порядок проведения экспертиза технической документации (стадия, этап, объем проверяемой 'документации, организация-эксперт);
  • программу работ, направленных на обеспечение требуемого уровня надежности разрабатываемой системы (при необходимости);
  • перечень работ по метрологическому обеспечению на всех стадиях создания системы с указанием их сроков выполнения и организаций-исполнителей (при необходимости).

2.8. В разделе “Порядок контроля и приемки системы” указывают:

  • виды, состав, объем и методы испытаний системы и ее составных частей (виды испытаний в соответствии с действующими нормами, распространяющимися на разрабатываемую систему);
  • общие требования к приемке работ по стадиям (перечень участвующих предприятий и организаций, место и сроки проведения), порядок согласования и утверждения приемочной документации;
  • ЗУ статус приемочной комиссии (государственная, [межведомственная, ведомственная).

2.9. В разделе “Требования к составу и содержанию работ по подготовке объекта автоматизации к вводу системы в действие” необходимо привести перечень основных мероприятий и их исполнителей, которые Следует выполнить при подготовке объекта автоматизации к вводу АС в действие.

В перечень основных мероприятий включают:

  • приведение поступающей в систему информации (в соответствии с' требованиями к информационному и лингвистическому обеспечению) к виду, пригодному для обработки с помощью ЭВМ;
  • изменения, которые необходимо осуществить в объекте автоматизации;
  • создание условий функционирования объекта автоматизации, при которых гарантируется соответствие создаваемой системы требованиям, содержащимся в ТЗ;
  • создание необходимых для функционирования системы подразделений и служб;
  • сроки и порядок комплектования штатов и обучения персонала.

Например, для АСУ приводят:

  • изменения применяемых методов управления;
  • создание условий для работы компонентов АСУ, при которых гарантируется соответствие системы требованиям, содержащимся в ТЗ.

2.10. В разделе “Требования к документированию” приводят:

  • согласованный разработчиком и Заказчиком системы перечень подлежащих разработке комплектов и видов документов, соответствующих требованиям ГОСТ 34.201 и НТД отрасли заказчика; перечень документов, выпускаемых на машинных носителях; требования к микрофильмированию документации;
  • требования по документированию комплектующих элементов межотраслевого применения в соответствии с требованиями ЕСКД и ЕСПД;
  • при отсутствии государственных стандартов, определяющих требования к документированию элементов системы, дополнительно включают требования к составу и содержанию таких документов.

2.11. В разделе “Источники разработки” должны быть перечислены документы и информационные материалы (технико-экономическое обоснование, отчеты о законченных научно-исследовательских работах, информационные материалы на отечественные, зарубежные системы-аналоги н др.), на основании которых разрабатывалось ТЗ и которые должны быть использованы при создании системы .

2.12. В состав ТЗ на АС при наличии утвержденных методик включают приложения, содержащие:

  • расчет ожидаемой эффективности системы;
  • оценку научно-технического уровня системы.

Приложения включают в состав ТЗ на АС по согласованию между разработчиком и заказчиком системы.

3. ПРАВИЛА ОФОРМЛЕНИЯ

3.1. Разделы и подразделы ТЗ на АС должны быть размещены в порядке, установленном в разд. 2 настоящего стандарта.

3.2. ТЗ на АС оформляют в соответствии с требованиями ГОСТ 2.'105 на листах формата А4 по ГОСТ 2.301 без рамки, основной надписи и дополнительных граф к ней.

Номера листов (страниц) проставляют, начиная с первого листа, следующего за титульным листом, в верхней части листа (над текстом, посередине) после обозначения кода ТЗ на АС.

3.3. Значения показателей, норм и требований указывают, как правило, с предельными отклонениями или максимальным и минимальным значениями. Если эти показатели, нормы, требования однозначно регламентированы НТД, в ТЗ на АС следует приводить ссылку на эти документы или их разделы, а также дополнительные требования, учитывающие особенности создаваемой системы. Если конкретные значения показателей, норм и требований не могут быть установлены в процессе раз работки ТЗ на АС, в нем следует сделать запись о порядке установления и согласования этих показателей, норм и требований:

"Окончательное требование (значение) уточняется в процессе ... и согласовывается протоколом с ... на стадии ...". При этом в текст ТЗ на АС изменений не вносят.

3.4. На титульном листе помещают подписи заказчика, разработчика и согласующих организаций, которые скрепляют гербовой печатью. При необходимости титульный лист оформляют на нескольких страницах. Подписи разработчиков ТЗ на АС и должностных лиц, участвующих в согласовании и рассмотрении проекта ТЗ на АС, помещают на последнем листе.

Форма титульного листа ТЗ на АС приведена в приложении 2. Форма последнего листа ТЗ на АС приведена в приложении 3.

3.5. При необходимости на титульном листе ТЗ на АС допускается помещать установленные в отрасли коды, например: гриф секретности, код работы, регистрационный номер ТЗ и др.

3.6. Титульный лист дополнения к ТЗ на АС оформляют аналогично титульному листу технического задания. Вместо наименования “Техническое задание” пишут “Дополнение № ... к ТЗ на AC ... ”.

3.7. На последующих листах дополнения, к ТЗ на АС помещают основание для изменения, содержание изменения и ссылки на документы, в соответствии с которыми вносятся эти изменения.

3.8. При изложении текста дополнения к ТЗ следует указывать номера соответствующих пунктов, подпунктов, таблиц основного ТЗ на АС и т. п. и применять слова: “.заменить”, “дополнить”, “исключить”, “изложить в новой, редакции”.

Приложение 1

Рекомендуемое

ПОРЯДОК РАЗРАБОТКИ СОГЛАСОВАНИЯ И УТВЕРЖДЕНИЯ ТЗ НА АС

1. Проект ТЗ на АС разрабатывает организация-разработчик системы с участием заказчика на основании технических требований' (заявки; тактико-технического задания и т. п.). При конкурсной организации работ варианты проекта ТЗ на АС рассматриваются заказчиком, который - либо выбирает предпочтительный, вариант, либо на основании сопоставительного анализа подготавливает с участием будущего разработчика АС окончательный вариант ТЗ на AC.

2. Необходимость согласования проекта ТЗ на АС с органами государственного надзора и другими заинтересованными организациями определяют совместно заказчик системы и разработчик проекта ТЗ на АС. Работу по согласованию проекта ТЗ на AC осуществляют совместно разработчик ТЗ на АС и .заказчик системы, каждый в организациях своего министерства (ведомства).

3. Срок согласования проекта ТЗ на АС в каждой организации не должен превышать 15 дней со дня его получения. Рекомендуется рассылать на согласование экземпляры проекта ТЗ на АС (копий) одновременно во все организа-;, ции (подразделения).

4. Замечания по проекту ТЗ на АС должны быть представлены с техническим обоснованием. Решения по замечаниям должны быть приняты разработчиком проекта ТЗ на АС и заказчиком системы до утверждения ТЗ на АС.

5. Если при согласовании проекта ТЗ на АС возникли разногласия между разработчиком и заказчиком (или другими заинтересованными организациями), то составляется протокол разногласий (форма произвольная) и конкретное решение принимается в установленном порядке.

6. Согласование проекта ТЗ на АС разрешается оформлять отдельным документом (письмом). В, этом случае под грифом “Согласовано” делают ссылку на этот документ.

7. Утверждение ТЗ на АС осуществляют руководители предприятий (организаций) разработчика и заказчика системы.

8. ТЗ на АС (дополнение к ТЗ) до передачи его на утверждение должно быть проверено службой нормоконтроля организации - разработчика ТЗ и, при необходимости, подвергнуто метрологической экспертизе. Копии, утвержденного ТЗ на АС в 10-дневный срок после утверждения высылаются разработчиком ТЗ на АС участникам создания системы.

10. Согласование и утверждение дополнений к ТЗ на АС проводят в порядке, установленном для ТЗ на АС.

11. Изменения к ТЗ на АС не допускается утверждать после представления системы для ее очереди на приемо-сдаточные испытания.

12. Регистрация, учет и хранение ТЗ на АС и дополнений к нему проводят в соответствии, с требованиями ГОСТ 2.501.

ПРИЛОЖЕНИЕ 2

Рекомендуемое

ФОРМА ТИТУЛЬНОГО ЛИСТА ТЗ НА АС

________________________________________________________

наименование организации - разработчика ТЗ на АС

УТВЕРЖДАЮ

Руководитель (должность, наименование предприятия - заказчика АС)

Личная подпись Расшифровка подписи

Печать

Дата

УТВЕРЖДАЮ

Руководитель (должность, наименование предприятия - разработчик” АС)

Личная подпись Расшифровка подписи

Печать

Дата

________________________________________________________

наименование вида АС

________________________________________________________

наименование объекта автоматизации

________________________________________________________

сокращенное наименование АС

ТЕХНИЧЕСКОЕ ЗАДАНИЕ

На ____ листах

              Действует с

        СОГЛАСОВАНО

Руководитель (должность, наименование согласующей организации)

Личная подпись Расшифровка подписи

Печать

Дата

                            ПРИЛОЖЕНИЕ 3

                            Рекомендуемое

ФОРМА ПОСЛЕДНЕГО ЛИСТА ТЗ НА АС

(код ТЗ)

СОСТАВИЛИ

Наименование организации. предприятия | Должность исполнителя. | Фамилия имя, отчество | Подпись | Дата

СОГЛАСОВАНО

Наименование организации. предприятия | Должность исполнителя. | Фамилия имя, отчество | Подпись | Дата

ПРИЛОЖЕНИЕ 4

Справочное

ПОЛОЖЕНИЯ ПО СОЗДАНИЮ ЕДИНОГО КОМПЛЕКСА СТАНДАРТОВ АВТОМАТИЗИРОВАННЫХ СИСТЕМ

1. И сходные предпосылки создания комплекса

1.1. Создание и внедрение автоматизированных систем различных классов и назначений ведется во многих отраслях промышленности по нормативно-технической документации, устанавливающей разнообразные организационно-методические и технические нормы, правила и положения, затрудняющие интеграцию систем и эффективное их совместное функционирование.

1.2. В период принятия Госстандартом СССР решения о совершенствовании межотраслевых комплексов стандартов действовали следующие комплексы и системы стандартов, устанавливающие требования к различным видам АС:

1) единая система стандартов автоматизированных систем управления (24-я система), распространяющаяся на АСУ, АСУП, АСУ ТП и другие организационно-экономические системы;
2) комплекс стандартов (система 23501); распространяющихся на системы автоматизированного проектирования;
3) четвертая группа 14-й системы стандартов, распространяющаяся на автоматизированные системы технологической подготовки производства.

1.3. Практика применения стандартов на АСУ, САПР, АСУ ТП, АСТПП показала, что в них применяется одинаковый понятийный аппарат, имеется много общих объектов стандартизации, однако требования стандартов не согласованы между собой, имеются различия по составу и содержанию работ, различия по обозначению, составу, содержанию и оформлению документов и пр.

1.4. На фоне отсутствия единой технической политики в области создания АС многообразие стандартов не обеспечивало широкой совместимости АС при их взаимодействии, не позволяло тиражировать системы, тормозило развитие перспективных направлений использования средств вычислительной техники.

1.5. В настоящее время осуществляется переход к созданию сложных АС (за рубежом системы CAD - САМ), включающих в свой состав АСУ технологическими процессами и производствами, САПР - конструктора, САПР - технолога, АСНИ и др. системы. Использование противоречивых правил при создании таких систем приводит к снижению качества, увеличению стоимости работ, затягиванию сроков ввода АС в действие.

1.6. Единый комплекс стандартов и руководящих документов должен распространяться на автоматизированные системы различного назначения: АСНИ, САПР, ОАСУ, АСУП, АСУТП, АСУГПС, АСК, АСТПП, включая их интеграцию.

1.7. При разработке межотраслевых документов следует учитывать следующие особенности АС. как объектов стандартизации:

1) техническое задание является основным документом, в соответствии с которым проводят создание АС и приемку его заказчиком;

2) АС, как правило, создают проектным путем с комплектацией изделиями серийного я единичного производства и проведением строительных, монтажных, наладочных и пусковых работ, необходимых для ввода в действие АС;

3) в общем случае АС (подсистема АС) состоит из программно-технических (ПТК), программно-методических комплексов (ПМК) и компонентов технического, программного и информационного обеспечении. Компоненты этих видов обеспечении, а также ПМК и ПТК должны изготовляться и поставляется, как продукция производственно-технического, назначения. Компоненты могут входить в АС в качестве самостоятельных частей или могут быть объединены в комплексы;

4) создание АС в организациях (предприятиях) требует специальной подготовки пользователей и обслуживающего персонала системы;

5) функционирование АС и комплексов обеспечивается совокупностью организационно-методических документов, рассматриваемых в процессе создания как компоненты правового, методического, лингвистического, математического, организационного и др. вдов обеспечения. Отдельные решения, получаемые в процессе разработки этих обеспечении, могут реализовываться в виде компонентов технического, программного или информационного обеспечении;

6) совместное функционирование и взаимодействие различных систем я комплексов осуществляется на базе локальных сетей ЭВМ.

7) Спецификации и соглашения, принятые для локальных сетей ЭВМ обязательны для обеспечения совместимости систем, комплексов и компонентов.

8) Взаимосвязь ЕКС АС с другими системами и комплексами стандартов

2.1. Стандартизация в области АС является составной частью работ по обобщенной проблеме “Информационная технология”.

2.2. Единый комплекс стандартов руководящих документов на автоматизированные системы совместно с другими системами и комплексами стандартов должен образовывать полное нормативно-техническое обеспечение процессов создания и функционирования АС.

2.3. ЕКС АС должен охватывать специфические для автоматизированных систем направления стандартизации и распространять традиционные направления стандартизации на программно-технические, программно-методические комплексы и автоматизированные системы в целом.

2.4. Направления и задачи стандартизации при нормативно-техническом обеспечении процессов создания и функционирования АС группируют следующим образом:

1) установление технических требований к продукции;
2) регламентация методов испытаний и правил аттестации и сертификации продукции;
3) регламентация правил и порядка разработки;
4) установление правил документирования;
5) обеспечение совместимости;
6) регламентация организационно-методических вопросов функционирования систем.

Направления 1-4 являются традиционными при разработке, изготовлении и поставке продукции. Направления 5, 6 являются специфичными и вытекают из особенностей, присущих АС.

2.5. Обеспеченность АС в целом и их составных частей нормативно-технической документацией в рамках принятых направлений и задач стандартизации различна. Компоненты технического, программного и информационного обеспечении, как продукцию производственно-технического назначения, рассматривают, соответственно, как конструкторские, программные и информационные изделия. На эти изделия распространяются действующие комплексы стандартов ЕСКД. СРПП, ЕСПД, СГИП, УСД, классификаторы и кодификаторы технико-экономической информации, комплексы стандартов вида “ОТТ”, “Методы испытаний”, “ТУ”, а также ОТТ заказчика.

2.5.1. Весь жизненный цикл конструкторских изделий полностью обеспечен нормативно-технической документацией, действующей в машиностроении и приборостроении.

2.5.2. Программные изделия обеспечены НТД, входящей в ЕСПД и ОТТ заказчика. Однако область распространения этих НТД должна быть расширена с целью отражения вопросов, связанных с разработкой, созданием, распространением и эксплуатацией программных изделий.

2.5.3. Информационные изделия в настоящее время не обеспечены НТД, хотя отдельные вопросы проработаны в рамках УСД, классификаторах и кодификаторах технико-экономической информации.

2.6. Программно-технические и программно-методические комплексы рассматриваются как сложные изделия, не имеющие аналогов в машиностроении, Учитывая статус ПТК и ПМК. как продукции производственно-технического назначения, правила и порядок их разработки должен быть аналогичен требованиям, установленным стандартами системы разработки и постановки продукции на производство (СРПП).


ГОСТ 34.603-92

УДК 65.015.13.011.66:006.354 Группа П87

ГОСТ 34.603—92

ИНФОРМАЦИОННАЯ ТЕХНОЛОГИЯ

ВИДЫ ИСПЫТАНИЙ АВТОМАТИЗИРОВАННЫХ СИСТЕМ

Information technology. Types tests automated systems

ОКСТУ 0034

Дата введения 01.01.93

Настоящий стандарт распространяется на автоматизированные системы (АС), используемые в различных видах деятельности (исследование, проектирование, управление и т. п.), включая их сочетания, создаваемые в организациях, объединениях и на предприятиях (далее - организациях).

Стандарт устанавливает виды испытаний АС и общие требования к их проведению.

Термины, применяемые в настоящем стандарте, и их определения - по ГОСТ 34.003.

Требования настоящего стандарта, кроме пп. 2.2.4, 4.4, 4.5, являются обязательными, требования пп. 2.2.4, 4.4, 4.5 - рекомендуемые.

1. ОБЩИЕ ПОЛОЖЕНИЯ

1.1. Испытания АС проводят на стадии “Ввода в действие” по ГОСТ 34.601 с целью проверки соответствия создаваемой АС требованиям технического задания (ТЗ).

1.2. Испытания АС представляют собой процесс проверки выполнения заданных функций системы, определения и проверки соответствия требованиям ТЗ количественных и (или) качественных характеристик системы, выявления и устранения недостатков в действиях системы, в разработанной документации.

1.3. Для АС устанавливают следующие основные виды испытаний:

1) предварительные;
2) опытная эксплуатация;
3) приемочные.

Примечания:

  1. Допускается дополнительно проведение других видов испытаний АС ч их частей.
  2. Допускается классификация приемочных испытаний в зависимости от статуса приемочной комиссии (состав членов комиссии и уровень его утверждения).
  3. Виды испытаний и статус приемочной комиссии устанавливают в договоре и (или) ТЗ.

1.4. В зависимости от взаимосвязей испытываемых в АС объектов испытания могут быть автономные или комплексные. Автономные испытания охватывают части АС. Их проводят по мере готовности частей АС к сдаче в опытную эксплуатацию. Комплексные испытания проводят для групп, взаимосвязанных частей АС или для АС в целом.

1.5. Для планирования проведения всех видов испытаний разрабатывают документ “Программа и методика испытаний”. Разработчик документа устанавливается в договоре или ТЗ.

1.6. Программа и методика испытаний должны устанавливать необходимый и достаточный объем испытаний, обеспечивающий. заданную достоверность получаемых результатов.

1.7. Программа и методика испытаний может разрабатываться на AC n целом, на части АС. В качестве приложения могут включаться тесты (контрольные примеры).

1.8. Предварительные испытания АС проводят для определения ее работоспособности и решения вопроса о возможности приемки AC n опытную эксплуатацию.

1.9. Предварительные испытания следует выполнять после проведения разработчиком отладки и тестирования поставляемых программных и технических средств системы и представления им соответствующих документов о их готовности к испытаниям, а также после ознакомления персонала АС с эксплуатационной документацией.

1.10. Опытную эксплуатацию АС проводят с целью определения фактических значений количественных и качественных характеристик АС и готовности персонала к работе в условиях функционирования АС, определения фактической эффективности АС,. корректировке (при необходимости) документации.

1.11. Приемочные испытания АС проводят для определения. соответствия АС техническому заданию, оценки качества .опытной эксплуатации и решения вопроса о возможности приемки АС в постоянную эксплуатацию.

1.12. Приемочным испытаниям АС должна предшествовать ее опытная эксплуатация на объекте.

1.13. В зависимости от вида требований, предъявляемых к АС на испытаниях, проверке или аттестации в ней подвергают:

  • комплекс программных н технических средств.
  • персонал;
  • эксплуатационную документацию, регламентирующую деятельность персонала при Функционировании АС;
  • АС в целом.

1.14. При испытаниях АС проверяют:

  • качество выполнения комплексом программных и технических средств автоматических функций во всех режимах функционирования АС согласно ТЗ на создание АС;
  • знание персоналом эксплуатационной документации ц наличие у него навыков, необходимых для выполнения установленных функций во всех режимах функционирования АС, согласно ТЗ на создание АС;
  • полноту содержащихся в эксплуатационной документации указании персоналу по выполнению им функций во всех режимах функционирования АС согласно ТЗ на создание АС;
  • количественные и (или) качественные характеристики выполнения автоматических и автоматизированных функций АС в соответствии с ТЗ;
  • другие свойства АС, которым она должна соответствовать по ТЗ.

1.15. Испытания АС следует проводить на объекте заказчика. По согласованию между заказчиком и разработчиком предварительные испытания и приемку программных средств АС допускается проводить на технических средствах разработчика при создании условий получения достоверных результатов испытаний.

1.16. Допускается последовательное проведение испытаний и сдача частей АС в опытную и постоянную эксплуатацию при соблюдении установленной в ТЗ очередности ввода АС в действие.

2. ПРЕДВАРИТЕЛЬНЫЕ ИСПЫТАНИЯ

2.1. Предварительные испытания АС могут быть:

  • автономные;
  • комплексные.

2.2. Автономные испытания

2.2.1. Автономные испытания АС следует проводить в соответствии с программой и методикой автономных испытаний, разрабатываемых для каждой части АС.

2.2.2. В программе автономных испытаний указывают:

  • перечень функций, подлежащих испытаниям;
  • описание взаимосвязей объекта испытаний с другими частями АС;
  • условия, порядок и методы проведения испытаний и обработки результатов;
  • критерии приемки частей по результатам испытаний.

К программе автономных испытаний следует прилагать график проведения автономных испытаний.

2.2.3. Подготовленные и согласованные тесты (контрольные примеры) на этапе автономных испытаний должны обеспечить:

  • полную проверку функций и процедур по перечню, согласованному с заказчиком;
  • необходимую точность вычислений, установленную в ТЗ;
  • проверку основных временных характеристик функционирования программных средств (в тех случаях, когда это является существенным);
  • проверку надежности и устойчивости функционирования программных и технических средств.

2.2.4. В качестве исходной информации для теста рекомендуется использовать фрагмент реальной информации организации-заказчика в объеме, достаточном для обеспечения необходимой достоверности испытаний.

2.2.5 Результаты автономных испытании частей АС следует фиксировать в протоколах испытаний. Протокол должен содержать заключение о возможности (невозможности) допуска части АС к комплексным испытаниям.

2.2.6. В случае, если проведенные автономные испытания будут признаны недостаточными, либо будет выявлено нарушение требований регламентирующих документов по составу или содержанию документации, указанная часть АС может быть возвращена на доработку и назначен новый срок испытаний.

2.3. Комплексные испытания

2.3.1. Комплексные испытания АС проводят путем выполнения комплексных тестов. Результаты испытаний отражают в протоколе. Работу завершают оформлением акта приемки в опытную эксплуатацию.

2.3.2. В программе комплексных испытаний АС или частей" АС указывают:

  • перечень объектов испытания;
  • состав предъявляемой документации;
  • описание проверяемых взаимосвязей между объектами испытаний;
  • очередность испытаний частей АС;
  • порядок и методы испытаний, в том числе состав программных средств и оборудования, необходимых для проведения испытаний, включая специальные стенды и полигоны.

2.3.3. Для проведения комплексных испытаний должны быть представлены:

  • программа комплексных испытаний;
  • заключение по автономным испытаниям соответствующих частей АС и устранение ошибок и замечаний, выявленных при автономных испытаниях;
  • комплексные тесты;
  • программные и технические средства и соответствующая им эксплуатационная документация.

2.3.4. При комплексных испытаниях допускается использовать в качестве исходной информацию, полученную на автономных испытаниях частей АС.

2.3.5. Комплексный тест должен:

  • быть логически увязанным;
  • обеспечивать проверку выполнения функций частей АС во всех режимах функционирования, установленных в ТЗ на АС, в том числе всех связей между ними;
  • обеспечивать проверку реакции системы на некорректную информацию и аварийные ситуации.

2.3.6. Протокол комплексных испытаний должен содержать заключение о возможности (невозможности) приемки АС в опытную эксплуатацию, а также перечень необходимых доработок и рекомендуемые сроки их выполнения.

После устранения недостатков проводят повторные комплексные испытания в необходимом объеме.

3. ОПЫТНАЯ ЭКСПЛУАТАЦИЯ

3.1. Опытную эксплуатацию проводят в соответствии с программой, в которой указывают:

  • условия и порядок функционирования частей АС и АС в целом;
  • продолжительность опытной эксплуатации, достаточную для проверки правильности функционирования АС при выполнении каждой функции системы и готовности персонала к работе в условиях функционирования АС;
  • порядок устранения недостатков, выявленных в процессе опытной эксплуатации.

3.2. Во время опытной эксплуатации АС ведут рабочий журнал, в который заносят сведения о продолжительности функционирования АС, отказах, сбоях, аварийных ситуациях, изменениях параметров объекта автоматизации, проводимых корректировках документации и программных средств, наладке, технических средств. Сведения фиксируют в журнале с указанием даты и ответственного лица. В журнал могут быть занесены замечания персонала по удобству эксплуатации АС.

3.3. По результатам опытной эксплуатации принимают решение о возможности (или невозможности) предъявления частей АС и системы в целом на приемочные испытания.

Работа завершается оформлением акта о завершении опытной эксплуатации и допуске системы к приемочным испытаниям.

4. ПРИЕМОЧНЫЕ ИСПЫТАНИЯ

4.1. Приемочные испытания проводят в соответствии с программой, в которой указывают:

  • перечень объектов, выделенных в системе для испытаний и перечень требований, которым должны соответствовать объекты .(со ссылкой на пункты ТЗ);
  • критерии приемки системы и ее частей;
  • условия и сроки проведения испытаний;
  • средства для проведения испытаний;
  • фамилии лиц, ответственных за проведение испытаний;
  • методику испытаний и обработки их результатов;
  • перечень оформляемой документации.

4.2. Для проведения приемочных испытаний должна - быть предъявлена следующая документация:

  • техническое задание на создание АС;
  • акт приемки в опытную эксплуатацию;
  • рабочие журналы опытной эксплуатации;
  • акт завершения опытной эксплуатации и допуска АС к приемочным испытаниям;
  • программа и методика испытаний.

Приемочные испытания следует проводить на функционирующем объекте.

4.3. Приемочные испытания в первую очередь должны включать проверку:

  • полноты и качества реализации функций при штатных, предельных, критических значениях параметров объекта автоматизации и в других условиях функционирования АС, указанных в ТЗ;
  • выполнения каждого требования, относящегося к интерфейсу системы;
  • работы персонала в диалоговом режиме;
  • средств и методов восстановления работоспособности АС после отказов;
  • комплектности и качества эксплуатационной документации.

4.4. Проверку полноты и качества выполнения функций АС рекомендуется проводить в два этапа. На первом этапе проводят испытания отдельных функций (задач, комплексов задач). При этом проверяют выполнение требований ТЗ к функциям (задачам, комплексам задач). На втором этапе проводят проверку взаимодействия задач в системе и выполнение требований ТЗ к системе в целом.

4.5. По согласованию с заказчиком проверка задач в зависимости от их специфики может проводиться автономно или в составе комплекса. Объединение задач при проверке в комплексах целесообразно проводить с учетом общности используемой информации и внутренних связей.

4.6. Проверку работы персонала в диалоговом режиме проводят с учетом полноты и качества выполнения функций системы. в целом.

Проверке подлежит:

  • полнота сообщений, директив, запросов, доступных оператору и их достаточность для эксплуатации системы;
  • сложность процедур диалога, возможность работы персонала без специальной подготовки;
  • реакция системы и ее частей па ошибки оператора, средства сервиса.

4.7. Проверка средств восстановления работоспособности АС после отказов ЭВМ должна включать:

  • проверку наличия в эксплуатационной документации рекомендаций по восстановлению работоспособности и полноту их описания;
  • практическую выполнимость рекомендованных процедур;
  • работоспособность средств автоматического восстановления;
  • функций (при их наличии).

4.8. Проверку комплектности и качества эксплуатационной документации следует проводить путем анализа документации на соответствие требованиям нормативно-технических документов я ТЗ.

4.9. Результаты испытаний объектов, предусмотренных программой, фиксируют в протоколах, содержащих следующие разделы:

  • назначение испытаний и номер раздела требований ТЗ на АС, по которому проводят испытание;
  • состав технических и программных средств, используемых при испытаниях;
  • указание методик, в соответствии с которыми проводились испытания, обработка и оценка результатов;
  • условия проведения испытаний и характеристики исходных данных;
  • средства хранения и условия доступа к конечной, тестирующей программе;
  • обобщенные результаты испытаний;
  • выводы о результатах испытаний и соответствии созданной системы или ее частей определенному разделу требований ТЗ на АС.

4.10. Протоколы испытаний объектов- по всей программе обобщают в едином протоколе, на основании которого делают заключение о соответствии системы требованиям ТЗ на АС и возможности оформления акта приемки АС в постоянную эксплуатацию.

Работу завершают оформлением акта о приемке АС в постоянную эксплуатацию.


ГОСТ на информационные технологии

Некоторые ГОСТ на информационные технологии

ГОСТ 34

ГОСТ 34.601-90. Информационная технология. Автоматизированные системы. Стадии создания.
ГОСТ 34.602-89. Информационная технология. Техническое задание на создание автоматизированной системы
ГОСТ 34.603-92. Информационная технология. Виды испытаний автоматизированных систем

ГОСТ 19 - ЕСПД

ГОСТ 19.001-77. Единая система программной документации. Общие положения
ГОСТ 19.101-77. Единая система программной документации. Виды программ и программных документов
ГОСТ 19.102-77. Единая система программной документации. Стадии разработки
ГОСТ 19.104-78. Единая система программной документации. Основные надписи
ГОСТ 19.105-78. Единая система программной документации. Общие требования к программным документам
ГОСТ 19.106-78. Единая система программной документации. Требования к программным документам, выполненным печатным способом
ГОСТ 19.201-78. Единая система программной документации. Техническое задание. Требования к содержанию и оформлению
ГОСТ 19.202-78. Единая система программной документации. Спецификация. Требования к содержанию и оформлению
ГОСТ 19.401-78. Единая система программной документации. Текст программы. Требования к содержанию и оформлению
ГОСТ 19.402-78. Единая система программной документации. Описание программы
ГОСТ 19.501-78. Единая система программной документации. Формуляр. Требования к содержанию и оформлению
ГОСТ 19.502-78. Единая система программной документации. Общее описание. Требования к содержанию и оформлению
ГОСТ 19.506-79. Единая система программной документации. Описание языка. Требования к содержанию и оформлению

ОСТ

ОСТ 4.071.030. АСУП. Создание системы. Нормативы рабочего времени

Ссылки на другие коллекции ГОСТ


Created using
htm2chm 3.0

Download it NOW!


ОТРАСЛЕВОЙ СТАНДАРТ. АСУП. Создание системы. Нормативы трудоемкости.

ОТРАСЛЕВОЙ СТАНДАРТ

АВТОМАТИЗИРОВАННАЯ СИСТЕМА УПРАВЛЕНИЯ ПРЕДПРИЯТИЕМ

СОЗДАНИЕ СИСТЕМЫ

Нормативы трудоёмкости

ОСТ 4.071.030

Настоящий стандарт устанавливает нормативы трудоёмкости на работы по созданию и дальнейшему развитию автоматизированной системы управления предприятием (АСУП).

1. Общие положения.

1.1. Нормативы трудоёмкости на работы по созданию АСУП предназначены для:

а) планирования объёмов работ предприятиям и подразделениям предприятий;
б) анализа и оценки результатов деятельности предприятий-разработчиков АСУП;
в) прогнозирования затрат на работы по АСУП;
г) определения сметной стоимости создания и развития АСУП.

1.2. Нормативы трудоёмкости на работы по созданию АСУП в нормо-часах установлены для сложившихся в отрасли организационно-технических условий труда разработчиков АСУП.

1.3. Нормативы трудоёмкости представлены для систем, реализуемых на базе электронно-вычислительных машин и единой системы электронно-вычислительных машин.

1.4. Нормативы трудоёмкости на проектирование АСУП дифференцированы в зависимости от:

  • технологии обработки информации;
  • степени новизны создания АСУП;
  • сложности задач.

1.5. Технология обработки информации зависит от использования:

  • локальных массивов;
  • банка данных (БД).

1.6. Степень новизны определяется характером разработки АСУП:

1-я степень - индивидуальная разработка задач с целью развития АСУП, реализуемой на ЭВМ; разработка головных (типовых) проектов АСУП, реализуемых на ЕС ЭВМ.

Примечание. Создание АСУП на базе ЕС ЭВМ допускается только на основе использования головных проектов АСУП.

2-я степень - создание АСУП на базе ЕС ЭВМ на основе внедрения головных проектов АСУП при условии их частичной доработки; развитие АСУП за счет заимствования проектных решений в случае неполного соответствия их условиям предприятия;

3-я степень - привязка решений головных проектов АСУП.

1.7. Сложность задач и реализующих их программ различают четырьмя группами. Характеристики групп сложности задач и реализующих их программ определяются логической структурой указанных задач и программ (таблицы 1,2).

1.8. Нормативы трудоёмкости разработки АСУП при использовании локальных массивов приведены в таблицах 3-8, а при использовании БД - в таблицах 9-14.

1.9. Нормативы трудоемкости на постановку задачи по группам сложности приведены в таблицах3-6 и 9-12.

1.10. Нормативы трудоемкости, дифференцированные по этапам подготовки и выпуска технической документации, приведены в таблицах 4-6 и 10-12.

1.11. Нормативы трудоемкости на постановку задачи по группам сложности на один документ, массив (файл) приведены в таблицах 7 и 13.

1.12. Нормативы трудоемкости на разработку программ и программной документации по группам сложности программ и в зависимости от языка программирования на одну команду приведены в таблицах 8 и 14.

1.13. Нормативы трудоемкости на внедрение проектных решений АСУП, приведенные в настоящем стандарте, дифференцированы в зависимости от:

  • степени новизны создания АСУП;
  • сложности задач;
  • периодичности решения задач.

1.14. Трудоёмкость создания конкретной АСУП определяется в зависимости от степени новизны разработки, выбранной структуры построения информационной базы АСУП, количества и сложности задач и их программ.

1.15. Нормативы трудоемкости на проектирование, приведённые в таблицах 3,9, используются при планировании работ на уровне предприятия, а также при заключении договоров на создание АСУП. При заданных количествах входных и выходных документов, массивов (файлов) задачи, команд в программе используются нормативы трудоёмкости, приведенные в таблицах 7,8,13,14, с соответствующими нормами машинного времени.

1.16. Нормативы трудоемкости, приведённые в таблицах 4-8 и 10-14, используются при планировании работ на уровне подразделений.

1.17. Нормативы трудоемкости на внедрение, приведенные в таблицах 15-17, используются при планировании работ на уровнях предприятия и подразделений.

1.18. Для определения трудоемкости разработки автономных задач при развитии АСУП с использованием локальных массивов, если задача требует дополнительных затрат на обследование и формирование новых массивов (файлов), следует пользоваться коэффициентами, учитывающими долю общесистемной части на стадиях:

а) технического задания (экспресс-анализа и технико-экономического обоснования разработки) - 0,25 трудоёмкости постановки задачи;
б) технического проекта (решение вопросов информационного обеспечения) - 0,15 трудоёмкости постановки задачи;
в) внедрения (организационных работ) - 0,20 трудоёмкости проведения испытания задачи.

При использовании БД трудоёмкость на каждой стадии определяется по следующим коэффициентам:

а) технического задания (экспресс-анализа и технико-экономического обоснования разработки) - 0,13 трудоёмкости разработки программ и программной документации задачи;
в) внедрения (организационных работ) - 0,20 трудоёмкости проведения испытания задачи.

1.19. Если при анализе постановки задачи выявляется необходимость в разработке технического задания на программирование, то трудоемкость этой работы принимать равной 0,5 трудоёмкости постановки данной задачи.

1.20. При определении трудоёмкости разработки уникальных программ и программной документации для специализированных предприятий - разработчиков следует увеличивать соответствующие значения таблиц на 35%.

1.21. Трудоёмкость проведения нормоконтроля включена в трудоёмкость оформления подлинника.

1.22. Для удобства использования нормативов при планировании нормируемым работам присваиваются коды. Код работы десятичный (цифровой). Длина кода 6 знаков.

Х ХХ ХХ Х
| |  |  |
| |  |  Порядковый номер значения интервала в группах сложности (периодичности решения задачи для стадии внедрения
| |  Порядковый номер работы при дифференцировании работ при разработке постановки задачи программы и программной документации
| Порядковый номер работы в пределах стадий создания системы
Код стадии создания АСУП с учётом технологии обработки информации.

Первый знак кода работы - код стадии создания АСУП с учётом технологии обработки информации принимает следующие значения:

0 - внедрение системы;
1 - разработка технического задания АСУП с использованием локальных массивов;
2 - разработка технического задания АСУП с использованием БД;
3 - разработка технического проекта АСУП с использованием локальных массивов;
4 - разработка технического проекта АСУП с использованием БД;
5 - разработка рабочего проекта АСУП с использованием локальных массивов;
6 - разработка рабочего проекта АСУП с использованием БД;
7 - проведение испытаний на стадии внедрения на ЭВМ;
8 - проведение испытаний на стадии внедрения на ЕС ЭВМ.

1.23. Нормативы трудоёмкости, установленные настоящим стандартом, допускается использовать при создании отраслевой автоматизированной системы управления, автоматизированной системы управления производственным объединением, автоматизированной системы управления разрабатывающим предприятием, автоматизированной системы управления научно-производственным объединением.

1.24. Примеры расчёта трудоёмкости приведены в справочных приложениях 1 и 2.

2. Характеристики сложности задач и программ.

Характеристики задач по группам сложности приведены в таблице 1.

Таблица 1

Группа сложности задачи | Характеристики задачи
1 Алгоритмы, позволяющие решать задачи:

оптимального планирования;
многофакторного анализа;
расчёта нормативов;
прогнозирования.

2 Алгоритмы, позволяющие решать задачи:

оперативного планирования производством;
текущего планирования и регулирования трудовыми и материальными ресурсами;
управление технической подготовкой производства;
нормативного и аналитического учета

3 | Алгоритмы, позволяющие решать задачи синтетического бухгалтерского учета и отчётности.
4 | Алгоритмы, позволяющие осуществлять организацию массивов нормативно-справочной информации.

Характеристики программ по группам сложности приведены в таблице 2.

Таблица 2

Группа сложности программы | Характеристика программы
1 | Сложные логические программы, объединённые в систему программ; организующие программы; программы типа "Диспетчер"
2 | Программы сравнительно сложной логической структуры, отличающиеся разнообразием форм входных или выходных документов или сложностью получения данных.
3 | Программы несложной логической структуры с простой формой входных и выходных документов, не требующие модификации разработанных алгоритмов для ЭВМ.
4 | Программы расчетного характера, реализующие несложные алгоритмы вычислительного характера, не требующие модификации разработанных алгоритмов; программы ведения массивов.

3. Нормативы трудоёмкости.

3.1. Нормативы трудоёмкости на проектирование АСУП с использованием локальных массивов по степеням новизны приведены в таблице 3.

Таблица 3.

Код работы | Наименование работы | Трудоёмкость по степени новизны, нормо-часы.
 |  | 1 | 2 | 3
 | Разработка технического задания * | 10772 | 7863 | 4952
101000 | Организационно-техническая подготовка к обследованию объекта управления | 114 | 74 | 34
102000 | Обследование объекта управления | 2025 | 1546 | 1066
103000 | Анализ и оформление материалов обследования | 2772 | 2346 | 2008
104000 | Проведение исследований ** | – | – | –
105000 | Разработка плана мероприятий по подготовке объекта к внедрению системы | 123 | 80 | 38
106000 | Разработка основных требований к создаваемой системе, составление и согласование технического задания | 5558 | 3637 | 1626
107000 | Предварительный расчёт экономической эффективности разрабатываемой системы | 180 | 180 | 180
 | Разработка технического проекта * | 8873 | 5883 | 1547
301000 | Разработка и обоснование проектных решений по функциональной части системы | 2418 | 1694 | –
 | Постановка задачи и разработка алгоритма решения по группам сложности: |  |  |
302000 | 1 | 1468 | 1100 | 735
303000 | 2 | 1210 | 905 | 605
304000 | 3 | 742 | 555 | 370
305000 | 4 | 462 | 345 | 230
306000 | Разработка и обоснование проектных решений по информационному обеспечению системы | 3245 | 2286 | 1359
307000 | Разработка и обоснование проектных решений по математическому обеспечению системы | 1092 | 648 | –
308000 | Разработка и обоснование проектных решений по техническому обеспечению системы | 1392 | 897 | –
309000 | Проведение экспериментальных исследований ** | – | – | –
310000 | Расчёт экономической эффективности системы | 453 | 288 | 167
311000 | Уточнение плана мероприятий по подготовке объекта к внедрению системы и его частичная реализация | 266 | 70 | 21
 | Разработка технического проекта * | 6993 | 4980 | 3066
501000 | Уточнение и детализация проектных решений по функциональному обеспечению системы | 848 | 631 | 401
502000 | Уточнение и детализация проектных решений по информационному обеспечению системы | 1351 | 993 | 641
503000 | Уточнение и детализация проектных решений по математическому обеспечению системы | 447 | 338 | 215
504000 | Уточнение и детализация проектных решений по техническому обеспечению системы | 588 | 441 | 280
505000 | Разработка технологического процесса функционирования вычислительного центра объекта | 205 | 105 | –
506000 | Разработка (уточнение) технологического процесса сбора и обработки информации | 1497 | 938 | 485
 | Разработка программ и программной документации по группам сложности на языках программирования: |  |  |
 | типов языков Ассемблера, ЯСК: |  |  |
507000 | 1 | 2716 | 2035 | 1360
508000 | 2 | 1864 | 1400 | 930
509000 | 3 | 1473 | 1105 | 735
510000 | 4 | 672 | 505 | 335
 | на машинно-ориентировочных языках типов Фортран, РПГ: |  |  |
511000 | 1 | 2659 | 1995 | 1330
512000 | 2 | 1825 | 1370 | 910
513000 | 3 | 1441 | 1080 | 720
514000 | 4 | 658 | 495 | 330
 | на проблемно-ориентированных языках типов Кобол, ПЛ-1 |  |  |
515000 | 1 | 2564 | 1923 | 1280
516000 | 2 | 1760 | 1320 | 880
517000 | 3 | 1389 | 1040 | 695
518000 | 4 | 635 | 745 | 320
519000 | Уточнение расчёта экономической эффективности системы | 96 | 96 | 96
520000 | Завершение мероприятий по подготовке объекта к внедрению системы | 1961 | 1438 | 948

* Итоговые цифры трудоемкости даны только на общесистемные работы.

** Проведение исследований должно осуществляться при необходимости дополнительного обоснования требований к создаваемой системе.

3.2. Нормативы трудоёмкости на проектирование АСУП 1-й степени новизны с использованием локальных массивов по этапам разработки и оформления документации приведены в таблице 4.

Таблица 4.

Код работы | Наименование работы | Трудоёмкость разработки и оформление документации по этапам, нормо-часы
 |  | всего | разработка и оформление оригинала | оформление подлинника | согласование и утверждение подлинника | размножение, переплёт и передача документации заказчику | руководство ходом работ
102000 | Обследование объекта управления и оформление материалов обследования* | 4911 | 3364 | 538 | 314 | 269 | 426
105000 | Разработка плана мероприятий по подготовке объекта к внедрению системы | 123 | 41 | 25 | 16 | – | 41
106000 | Разработка основных требований к создаваемой системе и составление технического задания | 5558 | 3677 | 588 | 278 | 294 | 721
107000 | Предварительный расчёт экономической эффективности системы | 180 | 143 | 25 | 12 | – | –
301000 | Разработка и обоснование проектных решений по функциональной части системы | 2418 | 1613 | 2645 | 167 | 134 | 240
 | Постановка задачи и разработка алгоритма решения по группам сложности: |  |  |  |  |  |
302000 | 1 | 1468 | 1156 | 158 | 90 | 64 | –
303000 | 2 | 1210 | 954 | 129 | 75 | 52 | –
304000 | 3 | 742 | 593 | 78 | 39 | 32 | –
305000 | 4 | 462 | 382 | 40 | 22 | 18 | –
306000 | Разработка и обоснование проектных решений по информационному обеспечению системы | 3245 | 2050 | 337 | 209 | 168 | 481
307000 | Разработка и обоснование проектных решений по математическому обеспечению системы | 1092 | 681 | 111 | 77 | 59 | 164
308000 | Разработка и обоснование проектных решений по техническому обеспечению системы | 1399 | 850 | 138 | 93 | 72 | 246
309000 | Расчёт экономической эффективности системы | 453 | 348 | 60 | 45 | – | –
310000 | Уточнение плана мероприятий по подготовке объекта к внедрению системы и его частичная реализация | 266 | 181 | – | 60 | – | 25
501000 | Уточнение и детализация проектных решений по функциональному обеспечению системы | 848 | 514 | 102 | 59 | 50 | 123
502000 | Уточнение и детализация проектных решений по информационному обеспечению системы | 1351 | 831 | 134 | 76 | 64 | 246
503000 | Уточнение и детализация проектных решений по математическому обеспечению системы | 447 | 268 | 43 | 28 | 23 | 85
504000 | Уточнение и детализация проектных решений по техническому обеспечению системы | 588 | 343 | 56 | 33 | 29 | 127
505000 | Разработка технологического процесса функционирования вычислительного центра объекта | 205 | 121 | 21 | 12 | 10 | 41
506000 | Разработка технологического процесса сбора и обработки информации | 1497 | 950 | 135 | 76 | 66 | 270
 | Разработка программ и программной документации по группам сложности на языках программирования: |  |  |  |  |  |
 | типов языков Ассемблера, ЯСК: |  |  |  |  |  |
507000 | 1 | 2716 | 2174 | 322 | 113 | 107 | –
508000 | 2 | 1864 | 1494 | 232 | 66 | 72 | –
509000 | 3 | 1473 | 1183 | 190 | 44 | 56 | –
510000 | 4 | 672 | 540 | 78 | 29 | 25 | –
 | на машинно-ориентировочных языках типов Фортран, РПГ: |  |  |  |  |  |
511000 | 1 | 2659 | 2117 | 322 | 113 | 107 | –
512000 | 2 | 1825 | 1455 | 232 | 66 | 72 | –
513000 | 3 | 1441 | 1151 | 190 | 44 | 56 | –
514000 | 4 | 658 | 526 | 78 | 29 | 25 | –
 | на проблемно-ориентированных языках типов Кобол, ПЛ-1 |  |  |  |  |  |
515000 | 1 | 2564 | 2022 | 322 | 113 | 107 | –
516000 | 2 | 1760 | 1390 | 232 | 66 | 72 | –
517000 | 3 | 1389 | 1099 | 190 | 44 | 56 | –
518000 | 4 | 635 | 503 | 78 | 29 | 25 | –
519000 | Уточнение расчёта экономической эффективности системы | 96 | 52 | 24 | 12 | – | 8
520000 | Завершение мероприятий по подготовке объекта к внедрению системы | 1961 | 895 | – | – | – | 1066

* В значение трудоёмкости работы входят значения трудоёмкости работ 101000 и 103000 1-й степени новизны (таблица 3).

3.3. Нормативы трудоёмкости на проектирование АСУП 2-й степени новизны с использованием локальных массивов по этапам разработки и оформления документации приведены в таблице 5.

Таблица 5.

Код работы | Наименование работы | Трудоёмкость разработки и оформление документации по этапам, нормо-часы
 |  | всего | разработка и оформление оригинала | оформление подлинника | согласование и утверждение подлинника | размножение, переплёт и передача документации заказчику | руководство ходом работ
102000 | Обследование объекта управления и оформление материалов обследования* | 3966 | 2710 | 434 | 253 | 217 | 352
105000 | Разработка плана мероприятий по подготовке объекта к внедрению системы | 80 | 24 | 16 | 7 | – | 33
106000 | Разработка основных требований к создаваемой системе и составление технического задания | 3637 | 2359 | 377 | 205 | 189 | 507
107000 | Предварительный расчёт экономической эффективности системы | 180 | 143 | 25 | 12 | – | –
301000 | Разработка и обоснование проектных решений по функциональной части системы | 1694 | 1098 | 176 | 102 | 88 | 230
 | Постановка задачи и разработка алгоритма решения по группам сложности: |  |  |  |  |  |
302000 | 1 | 1100 | 819 | 142 | 81 | 59 | –
303000 | 2 | 905 | 675 | 116 | 67 | 47 | –
304000 | 3 | 555 | 421 | 70 | 35 | 29 | –
305000 | 4 | 345 | 273 | 36 | 20 | 16 | –
306000 | Разработка и обоснование проектных решений по информационному обеспечению системы | 2286 | 1616 | 259 | 151 | 129 | 131
307000 | Разработка и обоснование проектных решений по математическому обеспечению системы | 648 | 424 | 68 | 40 | 34 | 82
308000 | Разработка и обоснование проектных решений по техническому обеспечению системы | 897 | 581 | 93 | 54 | 46 | 123
309000 | Расчёт экономической эффективности системы | 288 | 228 | 35 | 25 | – | –
310000 | Уточнение плана мероприятий по подготовке объекта к внедрению системы и его частичная реализация | 70 | 38 | – | 16 | – | 16
501000 | Уточнение и детализация проектных решений по функциональному обеспечению системы | 631 | 350 | 56 | 33 | 28 | 164
502000 | Уточнение и детализация проектных решений по информационному обеспечению системы | 993 | 560 | 90 | 52 | 45 | 246
503000 | Уточнение и детализация проектных решений по математическому обеспечению системы | 338 | 161 | 26 | 15 | 13 | 123
504000 | Уточнение и детализация проектных решений по техническому обеспечению системы | 441 | 239 | 38 | 22 | 19 | 123
505000 | Разработка технологического процесса функционирования вычислительного центра объекта | 105 | 48 | 8 | 4 | 4 | 41
506000 | Разработка технологического процесса сбора и обработки информации | 938 | 574 | 92 | 54 | 46 | 172
 | Разработка программ и программной документации по группам сложности на языках программирования: |  |  |  |  |  |
 | типов языков Ассемблера, ЯСК: |  |  |  |  |  |
507000 | 1 | 2035 | 1547 | 290 | 97 | 101 | –
508000 | 2 | 1400 | 1067 | 209 | 59 | 65 | –
509000 | 3 | 1105 | 845 | 171 | 39 | 50 | –
510000 | 4 | 505 | 388 | 70 | 22 | 25 | –
 | на машинно-ориентировочных языках типов Фортран, РПГ: |  |  |  |  |  |
511000 | 1 | 1995 | 1507 | 290 | 97 | 101 | –
512000 | 2 | 1370 | 1037 | 209 | 59 | 65 | –
513000 | 3 | 1080 | 820 | 171 | 39 | 50 | –
514000 | 4 | 495 | 378 | 70 | 22 | 25 | –
 | на проблемно-ориентированных языках типов Кобол, ПЛ-1 |  |  |  |  |  |
515000 | 1 | 1923 | 1435 | 290 | 97 | 101 | –
516000 | 2 | 1320 | 987 | 209 | 59 | 65 | –
517000 | 3 | 1040 | 780 | 171 | 39 | 50 | –
518000 | 4 | 475 | 358 | 70 | 22 | 25 | –
519000 | Уточнение расчёта экономической эффективности системы | 96 | 52 | 24 | 12 | – | 8
520000 | Завершение мероприятий по подготовке объекта к внедрению системы | 1438 | 466 | – | – | – | 972

* В значение трудоёмкости работы входят значения трудоёмкости работ 101000 и 103000 2-й степени новизны (таблица 3).

3.4. Нормативы трудоёмкости на проектирование АСУП 3-й степени новизны с использованием локальных массивов по этапам разработки и оформления документации приведены в таблице 6.

Таблица 6.

Код работы | Наименование работы | Трудоёмкость разработки и оформление документации по этапам, нормо-часы
 |  | всего | разработка и оформление оригинала | оформление подлинника | согласование и утверждение подлинника | размножение, переплёт и передача документации заказчику | руководство ходом работ
102000 | Обследование объекта управления и оформление материалов обследования * | 3108 | 2068 | 331 | 281 | 166 | 262
105000 | Разработка плана мероприятий по подготовке объекта к внедрению системы | 38 | 11 | 7 | 4 | – | 16
106000 | Разработка основных требований к создаваемой системе и составление технического задания | 1626 | 1041 | 166 | 139 | 83 | 197
107000 | Предварительный расчёт экономической эффективности системы | 180 | 143 | 25 | 12 | – | –
 | Постановка задачи и разработка алгоритма решения по группам сложности: |  |  |  |  |  |
302000 | 1 | 735 | 550 | 110 | 35 | 40 | –
303000 | 2 | 605 | 455 | 90 | 28 | 32 | –
304000 | 3 | 370 | 280 | 55 | 17 | 18 | –
305000 | 4 | 230 | 170 | 35 | 12 | 13 | –
306000 | Анализ разработанных проектных решений по информационному, математическому и техническому обеспечению системы | 1359 | 809 | 130 | 76 | 65 | 279
309000 | Расчёт экономической эффективности системы | 167 | 132 | 20 | 15 | – | –
310000 | Уточнение плана мероприятий по подготовке объекта к внедрению системы и его частичная реализация | 21 | 9 | – | 4 | – | 8
501000 | Уточнение и детализация проектных решений по функциональному обеспечению системы | 401 | 208 | 33 | 19 | 18 | 123
502000 | Уточнение и детализация проектных решений по информационному обеспечению системы | 641 | 370 | 59 | 34 | 30 | 148
503000 | Уточнение и детализация проектных решений по математическому обеспечению системы | 215 | 112 | 18 | 10 | 9 | 66
504000 | Уточнение и детализация проектных решений по техническому обеспечению системы | 280 | 160 | 26 | 15 | 13 | 66
505000 | Разработка технологического процесса функционирования вычислительного центра объекта | 485 | 303 | 48 | 28 | 24 | 82
506000 | Разработка технологического процесса сбора и обработки информации | 485 | 303 | 48 | 28 | 24 | 82
 | Разработка программ и программной документации по группам сложности на языках программирования: |  |  |  |  |  |
 | типов языков Ассемблера, ЯСК: |  |  |  |  |  |
507000 | 1 | 1360 | 1020 | 205 | 65 | 70 | –
508000 | 2 | 930 | 700 | 140 | 44 | 46 | –
509000 | 3 | 735 | 550 | 110 | 35 | 40 | –
510000 | 4 | 335 | 250 | 50 | 15 | 20 | –
 | на машинно-ориентировочных языках типов Фортран, РПГ: |  |  |  |  |  |
511000 | 1 | 1330 | 990 | 205 | 65 | 70 | –
512000 | 2 | 910 | 680 | 140 | 44 | 46 | –
513000 | 3 | 720 | 535 | 110 | 35 | 40 | –
514000 | 4 | 330 | 245 | 50 | 15 | 20 | –
 | на проблемно-ориентированных языках типов Кобол, ПЛ-1 |  |  |  |  |  |
515000 | 1 | 1280 | 940 | 205 | 65 | 70 | –
516000 | 2 | 880 | 650 | 140 | 44 | 46 | –
517000 | 3 | 695 | 510 | 110 | 35 | 40 | –
518000 | 4 | 320 | 235 | 50 | 15 | 20 | –
519000 | Уточнение расчёта экономической эффективности системы | 96 | 52 | 24 | 12 | – | 8
520000 | Завершение мероприятий по подготовке объекта к внедрению системы | 948 | 436 | – | – | – | 512

* В значение трудоёмкости работы входят значения трудоёмкости работ 101000 и 103000 3-й степени новизны (таблица 3).

3.5. Нормативы трудоёмкости на постановку задачи при проектировании АСУП с использованием локальных массивов по степеням новизны приведены в таблице 7.

Таблица 7.

Код работы | Группа сложности задачи | Трудоёмкость на один документ или массив по степени новизны, нормо-часы.
 |  | 1 | 2 | 3
302007 | 1 | 98 | 74 | 52
303007 | 2 | 93 | 71 | 49
304007 | 3 | 74 | 56 | 38
305007 | 4 | 66 | 50 | 33

3.6. Нормативы трудоёмкости на разработку программ и программной документации при проектировании АСУП с использованием локальных массивов по степеням новизны и языкам программирования приведены в таблице 8.

Таблица 8.

Код работы | Языки программирования | Группы сложности программы | Трудоёмкость на одну команду по степеням новизны
 |  |  | 1 | 2 | 3
507008 | Типов языков Ассемблера, ЯСК | 1 | 0,78 | 0,59 | 0,40
508008 |  | 2 | 0,62 | 0,47 | 0,32
509008 |  | 3 | 0,59 | 0,45 | 0,30
510008 |  | 4 | 0,45 | 0,34 | 0,23
511008 | Машинно-ориентированные, типов Фортран, РПГ | 1 | 0,75 | 0,57 | 0,39
512008 |  | 2 | 0,60 | 0,46 | 0,31
513008 |  | 3 | 0,57 | 0,43 | 0,29
514008 |  | 4 | 0,43 | 0,33 | 0,22
515008 | Проблемно-ориентированные, типов Кобол, ПЛ-1 | 1 | 0,73 | 0,55 | 0,38
516008 |  | 2 | 0,58 | 0,44 | 0,30
517008 |  | 3 | 0,55 | 0,42 | 0,28
518008 |  | 4 | 0,42 | 0,32 | 0,21

3.7. Нормативы трудоёмкости на проектирование АСУП с использованием БД по степеням новизны приведены в таблице 9.

Таблица 9.

Код работы | Наименование работы | Трудоёмкость по степени новизны, нормо-часы.
 |  | 1 | 2 | 3
 | Разработка технического задания * | 10772 | 7863 | 4952
201000 | Организационно-техническая подготовка к обследованию объекта управления | 114 | 74 | 34
202000 | Обследование объекта управления | 2025 | 1546 | 1066
203000 | Анализ и оформление материалов обследования | 2772 | 2346 | 2008
204000 | Проведение исследований ** | – | – | –
205000 | Разработка плана мероприятий по подготовке объекта к внедрению системы | 123 | 80 | 38
206000 | Разработка основных требований к создаваемой системе, составление и согласование технического задания | 5558 | 3637 | 1626
207000 | Предварительный расчёт экономической эффективности разрабатываемой системы | 180 | 180 | 180
 | Разработка технического проекта * | 21359 | 15179 | 8990
401000 | Определение технико-экономических показателей, необходимых для управления объектом | 595 | 418 | 297
402000 | Разработка структуры автоматизированной системы управления объектом | 700 | 490 | 350
403000 | Доработка (выбор) языка описания информации | 2676 | 1873 | –
404000 | Обоснование состава задач, их взаимосвязей и разработка схем документооборота | 2150 | 1505 | 1075
405000 | Разработка проектных решений по техническому обеспечению системы | 1392 | 897 | –
406000 | Разработка (доработка) логической структуры базы данных БД. | 3192 | 2244 | 1596
407000 | Разработка физической организации базы данных БД | 2128 | 1492 | 1064
408000 | Разработка (доработка) алгоритмов формирования БД | 3380 | 2366 | 1690
409000 | Разработка (доработка) алгоритмов ведения БД | 4420 | 3536 | 2730
410000 | Расчёт экономической эффективности системы | 453 | 288 | 167
411000 | Уточнение плана мероприятий по подготовке объекта к внедрению системы и его частичная реализация | 266 | 70 | 21
 | Постановка задачи и разработка алгоритма решения по группам сложности: |  |  |
412000 | 1 | 1121 | 840 | 560
413000 | 2 | 924 | 695 | 465
414000 | 3 | 564 | 425 | 280
415000 | 4 | 347 | 260 | 175
 | Разработка рабочего проекта * | 3759 | 2577 | 1529
601000 | Разработка (доработка) системы программ управления данными *** | – | – | –
602000 | Разработка технологического процесса функционирования вычислительного центра объекта | 205 | 105 | –
603000 | Разработка (уточнение) технологического процесса сбора и обработки информации | 1497 | 938 | 485
 | Разработка программ и программной документации по группам сложности на языках программирования: |  |  |
 | типов языков Ассемблера, ЯСК: |  |  |
604000 | 1 | 2064 | 1550 | 1030
605000 | 2 | 1416 | 1060 | 710
606000 | 3 | 1118 | 840 | 560
607000 | 4 | 509 | 380 | 255
 | на машинно-ориентировочных языках типов Фортран, РПГ: |  |  |
608000 | 1 | 2021 | 1515 | 1010
609000 | 2 | 1386 | 1040 | 690
610000 | 3 | 1095 | 820 | 550
611000 | 4 | 498 | 350 | 250
 | на проблемно-ориентированных языках типов Кобол, ПЛ-1 |  |  |
612000 | 1 | 1949 | 1460 | 975
613000 | 2 | 1337 | 1000 | 670
614000 | 3 | 1056 | 790 | 530
615000 | 4 | 481 | 360 | 240
616000 | Уточнение расчёта экономической эффективности системы | 96 | 96 | 96
617000 | Завершение мероприятий по подготовке объекта к внедрению системы | 1961 | 1438 | 948

* Итоговые цифры трудоемкости даны только на общесистемные работы.

** Проведение исследований должно осуществляться при необходимости дополнительного обоснования требований к создаваемой системе.

*** Трудоёмкость разработки и отладки программ управления данными БД определяют по 1-й и 2-й группам сложности программ с использованием локальных массивов.

3.8. Нормативы трудоёмкости на проектирование АСУП 1-й степени новизны с использованием БД по этапам разработки и оформления документации приведены в таблице 10.

Таблица 10.

Код работы | Наименование работы | Трудоёмкость разработки и оформление документации по этапам, нормо-часы
 |  | всего | разработка и оформление оригинала | оформление подлинника | согласование и утверждение подлинника | размножение, переплёт и передача документации заказчику | руководство ходом работ
202000 | Обследование объекта управления и оформление материалов обследования * | 4911 | 3364 | 538 | 314 | 269 | 426
205000 | Разработка плана мероприятий по подготовке объекта к внедрению системы | 123 | 41 | 25 | 16 | – | 41
206000 | Разработка основных требований к создаваемой системе и составление технического задания | 5558 | 3677 | 588 | 278 | 294 | 721
207000 | Предварительный расчёт экономической эффективности системы | 180 | 143 | 25 | 12 | – | –
401000 | Определение технико-экономических показателей, необходимых для управления объектом. | 595 | 401 | 65 | 37 | 32 | 60
402000 | Разработка структуры автоматизированной системы управления объектом | 700 | 472 | 76 | 44 | 38 | 70
403000 | Разработка языка описания информации | 2676 | 1807 | 289 | 169 | 144 | 267
404000 | Обоснование состава задач, их взаимосвязей и разработка схем документооборота | 2150 | 1452 | 232 | 135 | 116 | 215
405000 | Разработка проектных решений по техническому обеспечению системы. | 1399 | 850 | 138 | 93 | 72 | 246
406000 | Разработка логической структуры базы данных БД. | 3192 | 2155 | 345 | 201 | 172 | 319
407000 | Разработка физической организации базы данных БД. | 2128 | 1436 | 230 | 134 | 115 | 213
408000 | Разработка алгоритмов формирования базы данных БД. | 3380 | 2282 | 365 | 212 | 183 | 338
409000 | Разработка алгоритмов ведения базы данных БД. | 4420 | 2983 | 478 | 278 | 239 | 442
410000 | Расчёт экономической эффективности системы | 453 | 348 | 60 | 45 | – | –
411000 | Уточнение плана мероприятий по подготовке объекта к внедрению системы и его частичная реализация | 266 | 181 | – | 60 | – | 25
 | Постановка задачи и разработка алгоритма решения по группам сложности: |  |  |  |  |  |
412000 | 1 | 1121 | 840 | 142 | 81 | 58 | –
413000 | 2 | 924 | 694 | 116 | 67 | 47 | –
414000 | 3 | 564 | 430 | 70 | 35 | 29 | –
415000 | 4 | 347 | 275 | 36 | 20 | 16 | –
601000 | Разработка системы программ управления данными БД** | – | – | – | – | – | –
602000 | Разработка технологического процесса функционирования вычислительного центра объекта | 205 | 121 | 21 | 12 | 10 | 41
603000 | Разработка технологического процесса сбора и обработки информации | 1497 | 950 | 135 | 76 | 66 | 270
 | Разработка программ и программной документации по группам сложности на языках программирования: |  |  |  |  |  |
 | типов языков Ассемблера, ЯСК: |  |  |  |  |  |
604000 | 1 | 2064 | 1566 | 295 | 98 | 105 | –
605000 | 2 | 1416 | 1076 | 210 | 60 | 70 | –
606000 | 3 | 1118 | 848 | 175 | 40 | 55 | –
607000 | 4 | 509 | 383 | 75 | 26 | 25 | –
 | на машинно-ориентировочных языках типов Фортран, РПГ: |  |  |  |  |  |
608000 | 1 | 2021 | 1523 | 295 | 98 | 105 | –
609000 | 2 | 1386 | 1046 | 210 | 60 | 70 | –
610000 | 3 | 1095 | 825 | 175 | 40 | 55 | –
611000 | 4 | 498 | 372 | 75 | 26 | 25 | –
 | на проблемно-ориентированных языках типов Кобол, ПЛ-1 |  |  |  |  |  |
612000 | 1 | 1949 | 1451 | 295 | 98 | 105 | –
613000 | 2 | 1337 | 997 | 210 | 60 | 70 | –
614000 | 3 | 1056 | 786 | 175 | 40 | 55 | –
615000 | 4 | 481 | 355 | 75 | 26 | 25 | –
616000 | Уточнение расчёта экономической эффективности системы | 96 | 52 | 24 | 12 | – | 8
617000 | Завершение мероприятий по подготовке объекта к внедрению системы | 1961 | 895 | – | – | – | 1066

* В значение трудоёмкости работы входит значение трудоёмкости работ 201000 и 203000 1-й степени новизны (таблица 9).

** Трудоёмкость разработки и отладки программ управления данными БД определяют по 1-й и 2-й группам сложности программ с использованием локальных массивов.

Основными элементами системы программ управления данными БД являются:

  • система программ для типовых процедур обработки информации (ввод, входной контроль, поиск, обновление, исключение, дополнение, вывод, печать, отображение, передача в канал и т.п.);
  • система программ для диалога с потребителем с БД (трансляция с проблемно-ориентированных языков на машинный и наоборот, обучение потребителей этому языку, модификация запроса, выдача справок о составе и структуре БД и т.п.)
  • система программ динамической перестройки памяти для эффективного использования её ресурсов.

3.9. Нормативы трудоёмкости на проектирование АСУП 2-й степени новизны с использованием БД по этапам разработки и оформления документации приведены в таблице 11.

Таблица 11.

Код работы | Наименование работы | Трудоёмкость разработки и оформление документации по этапам, нормо-часы
 |  | всего | разработка и оформление оригинала | оформление подлинника | согласование и утверждение подлинника | размножение, переплёт и передача документации заказчику | руководство ходом работ
202000 | Обследование объекта управления и оформление материалов обследования * | 3966 | 2710 | 434 | 253 | 217 | 352
205000 | Разработка плана мероприятий по подготовке объекта к внедрению системы | 80 | 24 | 16 | 7 | – | 33
206000 | Разработка основных требований к создаваемой системе и составление технического задания | 3637 | 2359 | 377 | 205 | 189 | 507
207000 | Предварительный расчёт экономической эффективности системы | 180 | 143 | 25 | 12 | – | –
401000 | Определение технико-экономических показателей, необходимых для управления объектом. | 418 | 282 | 45 | 26 | 23 | 42
402000 | Разработка структуры автоматизированной системы управления объектом | 490 | 331 | 53 | 31 | 26 | 49
403000 | Доработка языка описания информации | 1873 | 1265 | 202 | 118 | 101 | 187
404000 | Обоснование состава задач, их взаимосвязей и разработка схем документооборота | 1505 | 1016 | 163 | 95 | 81 | 150
405000 | Разработка проектных решений по техническому обеспечению системы. | 897 | 581 | 93 | 54 | 46 | 123
406000 | Доработка логической структуры базы данных БД. | 2244 | 1516 | 242 | 141 | 121 | 224
407000 | Разработка физической организации базы данных БД. | 1492 | 1007 | 161 | 94 | 81 | 149
408000 | Доработка алгоритмов формирования базы данных БД. | 2366 | 1597 | 256 | 149 | 128 | 236
409000 | Доработка алгоритмов ведения базы данных БД. | 3536 | 2387 | 382 | 223 | 191 | 353
410000 | Расчёт экономической эффективности системы | 288 | 228 | 35 | 25 | – | –
411000 | Уточнение плана мероприятий по подготовке объекта к внедрению системы и его частичная реализация | 70 | 38 | – | 16 | – | 16
 | Постановка задачи и разработка алгоритма решения по группам сложности: |  |  |  |  |  |
412000 | 1 | 840 | 581 | 130 | 74 | 55 | –
413000 | 2 | 695 | 483 | 105 | 62 | 45 | –
414000 | 3 | 425 | 297 | 65 | 33 | 30 | –
415000 | 4 | 260 | 187 | 35 | 20 | 18 | –
601000 | Разработка системы программ управления данными БД ** | – | – | – | – | – | –
602000 | Разработка технологического процесса функционирования вычислительного центра объекта | 105 | 48 | 8 | 4 | 4 | 41
603000 | Разработка технологического процесса сбора и обработки информации | 938 | 574 | 92 | 54 | 46 | 172
 | Разработка программ и программной документации по группам сложности на языках программирования: |  |  |  |  |  |
 | типов языков Ассемблера, ЯСК: |  |  |  |  |  |
604000 | 1 | 1550 | 1160 | 235 | 75 | 80 | –
605000 | 2 | 1060 | 795 | 160 | 50 | 55 | –
606000 | 3 | 840 | 630 | 125 | 40 | 45 | –
607000 | 4 | 380 | 285 | 55 | 18 | 22 | –
 | на машинно-ориентировочных языках типов Фортран, РПГ: |  |  |  |  |  |
608000 | 1 | 1515 | 1125 | 235 | 75 | 80 | –
609000 | 2 | 1040 | 775 | 160 | 50 | 55 | –
610000 | 3 | 820 | 610 | 125 | 40 | 45 | –
611000 | 4 | 350 | 255 | 55 | 18 | 22 | –
 | на проблемно-ориентированных языках типов Кобол, ПЛ-1 |  |  |  |  |  |
612000 | 1 | 1460 | 1070 | 235 | 75 | 80 | –
613000 | 2 | 1000 | 735 | 160 | 50 | 55 | –
614000 | 3 | 790 | 580 | 125 | 40 | 45 | –
615000 | 4 | 360 | 267 | 55 | 18 | 20 | –
616000 | Уточнение расчёта экономической эффективности системы | 96 | 57 | 21 | 10 | – | 8
617000 | Завершение мероприятий по подготовке объекта к внедрению системы | 1438 | 466 | – | – | – | 972

* В значение трудоёмкости работы входит значение трудоёмкости работ 201000 и 203000 2-й степени новизны (таблица 9).

** Трудоёмкость разработки и отладки программ управления данными БД определяют по 1-й и 2-й группам сложности программ с использованием локальных массивов.

3.10. Нормативы трудоёмкости на проектирование АСУП 3-й степени новизны с использованием БД по этапам разработки и оформления документации приведены в таблице 12.

Таблица 12.

Код работы | Наименование работы | Трудоёмкость разработки и оформление документации по этапам, нормо-часы
 |  | всего | разработка и оформление оригинала | оформление подлинника | согласование и утверждение подлинника | размножение, переплёт и передача документации заказчику | руководство ходом работ
202000 | Обследование объекта управления и оформление материалов обследования * | 3108 | 2068 | 331 | 281 | 166 | 262
205000 | Разработка плана мероприятий по подготовке объекта к внедрению системы | 38 | 11 | 7 | 4 | – | 16
206000 | Разработка основных требований к создаваемой системе и составление технического задания | 1626 | 1041 | 166 | 139 | 83 | 197
207000 | Предварительный расчёт экономической эффективности системы | 180 | 143 | 25 | 12 | – | –
401000 | Определение технико-экономических показателей, необходимых для управления объектом. | 297 | 200 | 32 | 19 | 16 | 30
402000 | Разработка структуры автоматизированной системы управления объектом | 350 | 236 | 38 | 22 | 19 | 35
404000 | Обоснование состава задач, их взаимосвязей и разработка схем документооборота | 1075 | 726 | 116 | 68 | 58 | 107
406000 | Доработка логической структуры базы данных БД. | 1596 | 1078 | 172 | 100 | 86 | 160
407000 | Доработка физической организации базы данных БД. | 1064 | 719 | 115 | 67 | 57 | 106
408000 | Доработка алгоритмов формирования базы данных БД. | 1690 | 1141 | 183 | 106 | 91 | 169
409000 | Доработка алгоритмов ведения базы данных БД. | 2730 | 1843 | 295 | 172 | 147 | 273
410000 | Расчёт экономической эффективности системы | 167 | 132 | 20 | 15 | – | –
411000 | Уточнение плана мероприятий по подготовке объекта к внедрению системы и его частичная реализация | 70 | 38 | – | 16 | – | 16
 | Постановка задачи и разработка алгоритма решения по группам сложности: |  |  |  |  |  |
412000 | 1 | 560 | 310 | 124 | 72 | 54 | –
413000 | 2 | 465 | 264 | 103 | 60 | 42 | –
414000 | 3 | 280 | 160 | 62 | 31 | 27 | –
415000 | 4 | 175 | 106 | 34 | 18 | 17 | –
601000 | Разработка системы программ управления данными БД ** | – | – | – | – | – | –
602000 | Уточнение технологического процесса сбора и обработки информации | 485 | 270 | 59 | 34 | 30 | 92
 | Разработка программ и программной документации по группам сложности на языках программирования: |  |  |  |  |  |
 | типов языков Ассемблера, ЯСК: |  |  |  |  |  |
604000 | 1 | 1030 | 770 | 155 | 50 | 55 | –
605000 | 2 | 710 | 530 | 105 | 35 | 40 | –
606000 | 3 | 560 | 420 | 85 | 25 | 30 | –
607000 | 4 | 255 | 190 | 40 | 10 | 15 | –
 | на машинно-ориентировочных языках типов Фортран, РПГ: |  |  |  |  |  |
608000 | 1 | 1010 | 750 | 155 | 50 | 55 | –
609000 | 2 | 690 | 510 | 210 | 105 | 35 | –
610000 | 3 | 550 | 410 | 85 | 25 | 30 | –
611000 | 4 | 250 | 185 | 40 | 10 | 15 | –
 | на проблемно-ориентированных языках типов Кобол, ПЛ-1 |  |  |  |  |  |
612000 | 1 | 975 | 715 | 155 | 50 | 55 | –
613000 | 2 | 670 | 490 | 105 | 35 | 40 | –
614000 | 3 | 530 | 390 | 85 | 25 | 30 | –
615000 | 4 | 240 | 175 | 40 | 10 | 15 | –
616000 | Уточнение расчёта экономической эффективности системы | 96 | 52 | 24 | 12 | – | 8
617000 | Завершение мероприятий по подготовке объекта к внедрению системы | 948 | 436 | – | – | – | 512

*В значение трудоёмкости работы входит значение трудоёмкости работ 201000 и 203000 3-й степени новизны (таблица 9).

** Трудоёмкость разработки и отладки программ управления данными БД определяют по 1-й и 2-й группам сложности программ с использованием локальных массивов.

3.11. Нормативы трудоёмкости на постановку задачи при проектировании АСУП с использованием БД по степеням новизны приведены в таблице 13.

Таблица 13.

Код работы | Группа сложности задачи | Трудоёмкость на один документ или массив по степени новизны, нормо-часы.
 |  | 1 | 2 | 3
412007 | 1 | 74 | 52 | 38
413007 | 2 | 71 | 49 | 35
414007 | 3 | 56 | 38 | 28
415007 | 4 | 50 | 33 | 23

3.6. Нормативы трудоёмкости на разработку программ и программной документации при проектировании АСУП с использованием БД по степеням новизны и языкам программирования приведены в таблице 14.

Таблица 14.

Код работы | Языки программирования | Группы сложности программы | Трудоёмкость на одну команду по степеням новизны
 |  |  | 1 | 2 | 3
604008 | Типов языков Ассемблера, ЯСК | 1 | 0,59 | 0,40 | 0,21
605008 |  | 2 | 0,47 | 0,32 | 0,17
606008 |  | 3 | 0,45 | 0,30 | 0,16
607008 |  | 4 | 0,34 | 0,23 | 0,14
608008 | Машинно-ориентированные, типов Фортран, РПГ | 1 | 0,58 | 0,39 | 0,20
609008 |  | 2 | 0,46 | 0,31 | 0,16
610008 |  | 3 | 0,44 | 0,29 | 0,15
611008 |  | 4 | 0,33 | 0,22 | 0,13
612008 | Проблемно-ориентированные, типов Кобол, ПЛ-1 | 1 | 0,56 | 0,38 | 0,19
613008 |  | 2 | 0,44 | 0,30 | 0,15
614008 |  | 3 | 0,42 | 0,28 | 0,14
615008 |  | 4 | 0,32 | 0,22 | 0,13

3.13. Нормативы трудоёмкости на внедрение АСУП 1-й степени новизны приведены в таблице 15.

Таблица 15.

Код работы | Наименование работы | Трудоёмкость по видам работ, нормо-часы
 |  | всего | проведение испытаний. | оформление технической документации после корректировки по результатам опытной эксплуатации | руководство ходом работ
 | Внедрение * | 5864 | 3944 | 469 | 1451
001000 | Подготовка условий для обеспечения эксплуатации системы | 1625 | 1223 | – | 402
002000 | Комплексная проверка готовности задач, подсистем и системы к сдаче в промышленную эксплуатацию | 1625 | 1223 | – | 402
 | Сдача задачи заказчику на контрольных примерах в зависимости от группы сложности: |  |  |  |
003000 | 1 | 82 | 82 | – | –
004000 | 2 | 57 | 57 | – | –
005000 | 3 | 41 | 41 | – | –
006000 | 4 | 25 | 25 | – | –
 | Приёмо-сдаточные испытания задачи с использованием действующей на объекте информации в зависимости от частоты их решения по группам сложности: |  |  |  |
 | 1 раз в сутки и более: |  |  |  |
007001 | 1 | 752 | 638 | 114 | –
008001 | 2 | 671 | 569 | 102 | –
009001 | 3 | 507 | 429 | 78 | –
010001 | 4 | 368 | 326 | 42 | –
 | то 1 раза в сутки и менее 1 раза в месяц: |  |  |  |
007002 | 1 | 1894 | 1604 | 290 | –
008002 | 2 | 1647 | 1395 | 252 | –
009002 | 3 | 1155 | 981 | 174 | –
010002 | 4 | 398 | 352 | 46 | –
011000 | Оформление и утверждение документации о сдаче задач и подсистем в промышленную эксплуатацию | 2204 | 1112 | 469 | 623
012000 | Приёмка системы в промышленную эксплуатацию | 410 | 386 | – | 24

* Итоговые цифры трудоёмкости даны только на общесистемные работы.

3.13. Нормативы трудоёмкости на внедрение АСУП 2-й степени новизны приведены в таблице 16.

Таблица 16.

Код работы | Наименование работы | Трудоёмкость по видам работ, нормо-часы
 |  | всего | проведение испытаний. | оформление технической документации после корректировки по результатам опытной эксплуатации | руководство ходом работ
 | Внедрение* | 5313 | 3887 | 352 | 1074
001000 | Подготовка условий для обеспечения эксплуатации системы | 1625 | 1223 | – | 402
002000 | Комплексная проверка готовности задач, подсистем и системы к сдаче в промышленную эксплуатацию | 1625 | 1223 | – | 402
 | Сдача задачи заказчику на контрольных примерах в зависимости от группы сложности: |  |  |  |
003000 | 1 | 66 | 66 | – | –
004000 | 2 | 49 | 49 | – | –
005000 | 3 | 33 | 33 | – | –
006000 | 4 | 20 | 20 | – | –
 | Приёмо-сдаточные испытания задачи с использованием действующей на объекте информации в зависимости от частоты их решения по группам сложности: |  |  |  |
 | 1 раз в сутки и более: |  |  |  |
007001 | 1 | 556 | 471 | 85 | –
008001 | 2 | 389 | 329 | 60 | –
009001 | 3 | 309 | 261 | 48 | –
010001 | 4 | 269 | 228 | 41 | –
 | то 1 раза в сутки и менее 1 раза в месяц: |  |  |  |
007002 | 1 | 1401 | 1186 | 215 | –
008002 | 2 | 955 | 808 | 147 | –
009002 | 3 | 704 | 596 | 108 | –
010002 | 4 | 290 | 247 | 43 | –
011000 | Оформление и утверждение документации о сдаче задач и подсистем в промышленную эксплуатацию | 1653 | 1055 | 352 | 246
012000 | Приёмка системы в промышленную эксплуатацию | 410 | 386 | – | 24

* Итоговые цифры трудоёмкости даны только на общесистемные работы.

3.13. Нормативы трудоёмкости на внедрение АСУП 3-й степени новизны приведены в таблице 17.

Таблица 17.

Код работы | Наименование работы | Трудоёмкость по видам работ, нормо-часы
 |  | всего | проведение испытаний. | оформление технической документации после корректировки по результатам опытной эксплуатации | руководство ходом работ
 | Внедрение * | 4762 | 3606 | 311 | 845
001000 | Подготовка условий для обеспечения эксплуатации системы | 1625 | 1223 | – | 402
002000 | Комплексная проверка готовности задач, подсистем и системы к сдаче в промышленную эксплуатацию | 1625 | 1223 | – | 402
 | Сдача задачи заказчику на контрольных примерах в зависимости от группы сложности: |  |  |  |
003000 | 1 | 58 | 58 | – | –
004000 | 2 | 41 | 41 | – | –
005000 | 3 | 25 | 25 | – | –
006000 | 4 | 16 | 16 | – | –
 | Приёмо-сдаточные испытания задачи с использованием действующей на объекте информации в зависимости от частоты их решения по группам сложности: |  |  |  |
 | 1 раз в сутки и более: |  |  |  |
007001 | 1 | 376 | 318 | 58 | –
008001 | 2 | 322 | 273 | 49 | –
009001 | 3 | 253 | 214 | 39 | –
010001 | 4 | 194 | 161 | 30 | –
 | то 1 раза в сутки и менее 1 раза в месяц: |  |  |  |
007002 | 1 | 947 | 802 | 145 | –
008002 | 2 | 790 | 669 | 121 | –
009002 | 3 | 577 | 489 | 88 | –
010002 | 4 | 207 | 175 | 32 | –
011000 | Оформление и утверждение документации о сдаче задач и подсистем в промышленную эксплуатацию | 1102 | 774 | 311 | 17
012000 | Приёмка системы в промышленную эксплуатацию | 410 | 386 | – | 24

* Итоговые цифры трудоёмкости даны только на общесистемные работы.

Приложение 1 (Справочное).

Приложение 2. (Справочное)

Пример расчёта трудоёмкости создания АСУП 1-й степени новизны по этапам разработки и оформления документации.

1. Исходные данные.

1.1. В качестве примера рассматривается трудоёмкость разработки технического проекта системы, приведенной в примере расчёта трудоёмкости создания АСУП (справочное приложение 1).

2.Определение трудоёмкости разработки технического проекта (ТП).

2.1. Трудоёмкость создания ТП складывается из трудоёмкости разработки:

  • общесистемной части;
  • задач по группам сложности;
  • массивов НСИ.

Трудоёмкость разработки общесистемной части технического проекта составляет 8873 нормо-часа (таблица 3 настоящего стандарта), в том числе по этапам разработки и оформления документации (таблица 4 настоящего стандарта):

  • разработка и оформление оригинала - 5723 нормо-часа;
  • оформление подлинника - 910 нормо-часа;
  • согласование и утверждение подлинника - 651 нормо-час;
  • размножение, переплёт и передача документации заказчику - 433 нормо-часа;
  • руководство ходом работ - 1156 нормо-часов.

2.2. Расчёт трудоёмкости разработки 30 задач и 20 массивов НСИ по этапам разработки и оформления документации в нормо-часах показан на примере 5 задач 1-й группы сложности (таблица 4 настоящего стандарта):

  • разработка и оформление оригинала 1156?; 5=5780;
  • оформление подлинника 158?; 5=790;
  • согласование и утверждение подлинника 90?; 5=450;
  • размножение, переплёт и передача документации заказчику 64?; 5=320.

Аналогичным образом рассчитана трудоёмкость разработки 20 задач 2-й группы сложности, 5 задач 3-й группы сложности и 20 массивов НСИ и составляет по этапам:

  • разработка и оформление оригинала - 29685 нормо-часа;
  • оформление подлинника - 3770 нормо-часа;
  • согласование и утверждение подлинника - 2135 нормо-час;
  • размножение, переплёт и передача документации заказчику - 1560 нормо-часа.

Итого трудоёмкость создания ТП по этапам разработки и оформления документации составляет:

  • разработка и оформление оригинала - 41188 нормо-часа;
  • оформление подлинника - 5470 нормо-часа;
  • согласование и утверждение подлинника - 3236 нормо-час;
  • размножение, переплёт и передача документации заказчику - 2313 нормо-часа;
  • руководство ходом работ - 1156 нормо-часов.

Трудоёмкость создания ТП в нормо-часах составляет:

41188 + 5470 + 3236 + 2313 + 1156 = 53363.

2.3.Расчёт трудоёмкости разработки других стадий создания АСУП по этапам разработки и оформления документации производится аналогичным образом.